Zotero Standalone upgrade won't add titles to child notes

I have just upgraded to and find that my new child notes are "untitled". They used to take the title from the first line of the note - that's no longer happening.

  • Running on Win 10...
  • Happens to me too sometimes. Usually when i copy text to a new note. When i type a note from scratch, it works better. Sometimes, when i restart Zotero desktop, the titles fill in. Definitely some sort of bug.
  • On some platforms it might not trigger a save on paste. Just pressing something else on the keyboard should trigger a save. (This also might be fixed in the upcoming Zotero 5.0.)
  • I'm having this problem too (SA, Win10, any browser). When I check the HTML of the note, any copied text now starts with a paragraph containing a comment saying "StartFragment". When I delete this paragraph the note then gets the first line as its title. (Because the paragraph contains only a comment, it doesn't show up when you view the note, you only see it when you edit the HTML.)

    Apparently this has been recognized as a problem before:


    I haven't tried the solution recommended by Whateverr in that post - I just manually delete the paragraph with the "StartFragment" comment in the HTML.
  • I have now tried Whateverr’s solution, which is to go into about:config (In Standalone it's: Preferences > Advanced > Open about:config) and set the "dom.event.clipboardevents.enabled" entry to "false". It seems to solve the "StartFragment" issue for me, too. I haven't encountered any side effects so far (I can still copy and paste from Google docs, which was one side effect Whateverr noted).
  • We'll see what we can do about the StartFragment issue, but note that setting dom.event.clipboardevents.enabled to false can break things.
  • edited April 15, 2017
    Actually I'm not seeing the StartFragment issue in the 5.0 beta on Windows 7 or 10. If someone does, let me know exactly where you're copying from.
Sign In or Register to comment.