Zotero saves pages only as Web Page transpators not working

Hello, I have not used zotero in firefox for about four weeks. I am on arch linux and have the latest firefox and zotero installed. No, yesterday I wanted to save a arxiv.org site as a arxiv entry but zotero only offers the generic "Save to zotero as Web Page" option. The same happens to all sites. So I think there is something wrong with the translators. But I cannot find the error. I have tried to reset the translators, to reinstall zotero and to use a new profile but nothing seems to help. Would be great, if someone could help me since I need zotero in my everyday work.
  • Is this with just the Firefox add-on or with Firefox add-on and standalone? Could we get exact version numbers of all relevant software (Firefox, Zotero for Firefox, and if applicable Zotero Standalone) as well as at least a couple of sample URLs?
  • edited 10 days ago
    Hello, here are some data:
    Firefox: 52.0.1 (64-bit)
    Add-on: 4.0.29.16
    Standalone: 4.0.29.10

    It happens with the add-on. I do not know how to use a translator from standalone version. Is it possible anyhow? When you mean the use of the search by DOI or ISBN, it works as expected.

    This are links which normally would use translators:
    https://arxiv.org/abs/1612.04992
    https://en.wikipedia.org/wiki/Quantum_chromodynamics

    but as I already told, it seams, that any site can be only saved as a Web Page. None of the translators seams to work...
  • You're automatically using Standalone when it's open while you're importing. Have you tried with Standalone entirely closed/quit?
  • I have tried this but it does not change anything.
  • OK, keep Standalone closed. Try number 10. here https://www.zotero.org/support/troubleshooting_translator_issues
    and if that doesn't work, get us the info under 11. but with a debug ID for loading/reloading the ArXiv page above (no need for a report ID).
  • Ok, I will give you the information soon... Thank you anyway for such quick replies.
  • The point 10 didn't help.
    So I provide the Debug ID: D970886586 coming from reloading the arxiv.org page.

    Maybe it is important, that my add-on is pointed to the same directory as my standalone version so they share the same library.
  • yes, that'd be expected. @dstillman could you take a look?
  • (3)(+0001519): Translators: Looking for translators for https://arxiv.org/abs/1612.04992
    (4)(+0000114): Translate: Binding sandbox to https://arxiv.org/abs/1612.04992


    That's the full log.

    @StaKaz could you wait for 30s or so after reloading the arxiv page when capturing debug output and submit another Debug ID? This looks rather incomplete.
  • edited 9 days ago
    Yes, here it is. With waiting for 40 seconds. But it says, that it has written 3 lines, as in the first case.
    Debug ID: D270739527
  • Something weird is going on here. Is this the official Firefox version from Mozilla, or a distro-specific package?

    But since you're using Standalone anyway, you could try installing the beta version of the new Zotero Connector for Firefox. (That page is for 5.0, but the new Firefox connector should work with Standalone 4.0 too.)
  • It works with the connector. This is a solution I can live with. However, there is an important feature missing while using connector. I cannot choose between different option (with or without snapshot, or which metadata to use). This freedom was really good and I hope it comes again someday...
  • edited 7 days ago
    Yes, you can — just right-click on the page. Firefox currently doesn't support custom context menu options for toolbar icons. (Chrome does, so the upcoming Chrome connector supports this via right-click on the toolbar icon itself.)
  • Oh, thank you, this was the information of the day ;) Just one thing: does this appear somewhere in a description. If not, maybe it could be added so everyone knows about it.
  • We'll definitely document that better when the connector is out of beta, yes. Right now, that information may actually add confusion given the various connector/add-on options available to users..
Sign In or Register to comment.