DOI metadata lookup not working

Tried to reset translators but still not working
  • I have no problem to lookup DOI. Do you have correct DOI?
  • Yes I have tried many LiborA
  • Could we get a couple of sample DOIs as well as an error report ID after a failed attempt to get metadata from that DOI
    https://www.zotero.org/support/reporting_problems
  • Here is a small sample of the Zotero Error Report. All DOI #'s do not work. A sample is 10.1111/eff.12024. There is no error report ID and nothing is bolded.

    [JavaScript Error: "www.medra.org:443 uses an invalid security certificate.

    The certificate is not trusted because the issuer certificate is unknown.
    The server might not be sending the appropriate intermediate certificates.
    An additional root certificate may need to be imported.

    Error code: SEC_ERROR_UNKNOWN_ISSUER
    "]
  • there is no error report ID after you click on submit error report? And no failure to send indication either?

    From the initial look of it, this seems like a connection issue on your end (that SSL error doesn't look right). On what type of internet connection are you (i.e. is it provided by some type of institution? When you hover over or click on the lock icon in your URL bar on this page, what does it say about the internet connection and who it is verfied by?
  • edited 28 days ago
    This is Standalone, I assume? The certificate for https://www.medra.org looks valid from here, so see SSL Certificate Error. That page is about syncing (which I'd guess also wouldn't work for you), but it'd be the same general problem. To start, provide the info here: Site Certificate Info.
  • This is Standalone.

    In Chrome (Windows), click the padlock icon → Connection and look at the “verified by” line. For full information, click on Certificate Information and look at “Issued to”, “Issued by”, and “Valid from”, as well as Issuer in the Details tab.

    This isn't working for me. When I click the padlock icon, I don't have a 'verified by' line.
  • This changed with Chrome 56, sorry about that. You now need to
    1. Click on the three bars Menu at the top right
    2. More Tools --> Developer Tools
    3. Click the Security Tab
    4. Click on "View Certificate"

  • Issued to: *.zotero.org
    Issued from: den-sv3800-rsa
    Valid from 10/28/16 to 11/2/18
  • OK, so your institution is intercepting traffic (with a Blue Coat appliance, it looks like). This paragraph from the linked page applies:
    If you are in an institutional environment, ask your network administrator if they have installed a “custom root certificate” in your browser. If so, you can try either using Zotero for Firefox instead or following the certificate override instructions for Zotero Standalone, but be aware that in either case your connection to Zotero is being intercepted and possibly monitored.
    The full version of Zotero for Firefox is going away, so you'll need to fix this in Standalone.

    I'm not sure if the cert_override.txt file is necessary in your case or just cert8.db. Try just the latter first.
  • edited 9 days ago
    I'm having the same problem. DOI lookup works fine in the firefox browser plugin, but not in standalone. I know my institution is intercepting traffic, so the question is how to make Zotero work anyway.

    I tried copying the cert8.db file from my firefox profile folder to the Zotero profile folder, but that didn't fix it. The certificate override instructions mention a "cert_override.txt" file, but I don't seem to have one of those. Is there a way to create one?
  • edited 8 days ago
    If they're intercepting traffic, cert8.db should be the relevant file, though it's possible you also need key3.db and secmod.db. cert_override.txt is only necessary for self-signed certificates for individual servers.

    Make sure you restart Zotero after copying.
Sign In or Register to comment.