Drag&drop multiple PDF from Zotero to Finder

It's not possible (at least on v5) to drag&drop multiple pdf selected in Zotero to the Finder or in the browser (gmail, drive, ...).
  • that's on Mac? IIRC the file drop&drag behavior isn't uniform across operating system. I don't think it has ever worked well in linux, but thought it worked on Mac.
  • Yes it's on Mac.
  • 1) Debug ID?

    2) What are you trying, exactly, and what's happening?

    Dragging multiple files should work fine. It's worked for years on macOS, and if I recall now should work (though possibly not quite as well) on Windows and Linux in 5.0.
  • edited February 23, 2017
    1) DebugID: D1295080859

    I had success with drag& drop of multiple files.

    In fact, the problem is an UX one: when you drag one file from Zotero in the Finder you can see the selected file in "transparency" but if you drag more than one file you have nothings that tell you you are dragging those files. The same append with parent item.

    In both case when you are over the finder but yet didn't release the button you don't have the traditional "+" sign that let you know you are doing a copy and not moving the files.

    Also on MacOS they should also have a little number that indicated how many files you are dragging: http://cdn.osxdaily.com/wp-content/uploads/2015/08/drag-drop-pictures-into-photos-app-icon-import-mac-os-x.jpg
Sign In or Register to comment.