[5.0 Beta] Renaming file title does not update filename in database

If I rename a file (e.g. pdf), by right-clicking on the name in the right-hand panel and making sure that "Rename associated file" is checked the following occurs:
1. File is renamed at the top of the right-hand column (in bold)
2. The file is renamed on the computer in "storage\[random folder]"
3. The "Filename" property in the right-hand column is NOT renamed/updated
4. When I double-click on the file in the centre pane, the error " File not found" comes up.
5. I can find the file with the new name in Windows Explorer and reattach

Using right-click "Rename File from Parent Metadata" works fine.

Version 5.0-beta.142+bb0fa73
  • This works for me. Debug ID?
  • mc
    edited February 21, 2017
    Debug ID is D1855057273. Renamed file from Kallen_2011_Understanding biostatistics.pdf to Kallen_2011_Understanding biostatistics1.pdf
  • mc
    edited February 22, 2017
    A related issue is that a file that could not be found, when I delete it from the record (right-click "Move Item to Trash..."), the record and file go into the Trash but can not be deleted from the Trash (both coloured grey). Usually, if deleting a file the record and file go into Trash but the file is black (can be deleted) while the record is grey (can't be deleted).
  • Can you confirm that this happens with ZotFile disabled?
  • Renaming works with Zotfile disabled (Doh!). Thanks for your help, I never thought to disable Zotfile -- I will send on a bug report. Now I just have orphan items in Trash. Any idea on removing them?
  • I can't reproduce that either, so that might be a ZotFile artifact as well, but can you either 1) empty the entire trash by right-clicking on it or 2) restore either of the items to the library and then delete again?

    If neither works, check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences.
  • Right-click on Trash worked (I did not know you could do that -- it's amazing what you learn).
  • mc
    edited February 24, 2017
    I thought this was solved disabling Zotfile but it was not (new Debug ID D2128375280). The other difference between reproducing this is that when I thought it was solved yesterday, I was on a Windows 7 machine, whereas not working is a Windows 10 machine.

    Please ignore. I updated to the latest build (5.0-beta.152+1633a73) and renaming seems to be working with and without Zotfile installed.
  • No, you were right — I fixed it in 152. (This was failing or not based solely on the speed of the operation.)
Sign In or Register to comment.