Access Date and electonic source info missing; Adding a new style set to Zotero

edited February 16, 2017
In Chicago-Turabian, correct citation format for sources accessed electronically include a short addendum naming the online database used and the date accessed. I am unable to generate citations in MS Word with Zotero that include these addendums, even when my entry in Zotero includes the DOI, URL, and date accessed in the individual entry for the item. Rather, they appear as standard entries that suggest I accessed a print copy of the source.

I am using Zotero on a Windows 10 box, MS Word 2010, running the latest version of Firefox, and using the web browser version of Zotero with the correct MS Word plug-in installed.

My questions:
1. Does Zotero support formatting for electronic sources or is it necessary to manually add the addendum (as I am currently doing)?
2. If Zotero does support it how does one turn the feature on?

Example:
Campbell Brown, "Consequentialize This," Ethics 121, no. 4 (July 2011): 752, accessed December 1, 2012, http://dx.doi.org/10.1086/660696.

Problem: everything that follows "752," doesn't appear. Rather the entry looks like this:
Campbell Brown, "Consequentialize This," Ethics 121, no. 4 (July 2011): 752.
  • You can check the include URL option in the Cite--> Styles tab of the Zotero preferences. I think that should add that information.

    (That said, this is ridiculous on Turabian's part and the should follow the Chicago Manual's lead on this. Everyone accesses journal articles electronically and while I'm all for adding DOIs, the access date is a joke and a waste of space -- which is why you'd never see this in an actual publication)
  • edited February 17, 2017
    AdamSmith:

    Thanks for your reply. While following your suggestion, I stumbled on the full solution.

    It turns out that many style formats are not included by default in a Zotero profile. My confusion arose because I assumed that there was no specific style set for Turabian, which requires that the "accessed date" be included? I was getting incomplete citations because I was using its close cousin, Chicago, which doesn't require the access date. Chicago is included by default during installation, Turabian is not. I just needed to add Turabian to the style sets in my personal installation of Zotero and that did the trick.

    To add a new style set to your preferred style sets in your own installation of Zotero,

    Go to: PREFERENCES---> Cite
    In the dialog box, there should be a hyperlink labeled: "Additional Styles"
    Clicking on it brings up over 8,500 additional style options in alphabetical order. Locate the one you need and click on it. You will be asked if you want to install the style. Choose "Install" and then close the window.

    With that done, when inserting a citation, the style you've added will appear in the dialog box. Select it and proceed with generating the citation.

    And Adam...I agree with you. The Chicago/Turabian format (literally like every other style sheet I have ever used) is arcane, capricious, and idiosyncratic. It seems like the rule makers never use the confounding styles they mandate that others use. And how about 8,520 different style sets...Really? Are you truly serious, worlds of Academia and Publishing? But that's another discussion. Thank you for taking the time to respond to my question, Adam.

    Gordon Grant
Sign In or Register to comment.