zot5 bug: when clicking on local link (epub works with blank windows, pdf doesn't)[solved]

edited February 22, 2017
I store my epubs/pdf in a sync local folder (using google drive). So when I click on the pdf it's opened in adobe (acrobat pro).

C:\GDrive\Library\book.epub : The epub is opened. But it also open a big zotero blank windows which stays, even after closing the epub app.

C:\GDrive\Library\book.pdf : does not work. It opens a zotero blank windows, containing only a menu file & edit + this error:

Adobe PDF Document
There is a problem with Adobe Acrobat/Reader.
If it is running, please exit and try again. (1014:1014)

The white (and sometime black) blank windows is bigger than my screen so I need to move it to see the top of it and to be able to close it .

EDIT: bug remains when running zot as admin
  • I cannot seem to reproduce this with Adobe Reader installed.

    Does this also happen with Zotero 4? Does it work normally if you use a folder that isn't synced?
  • edited February 12, 2017
    @adomasven No, I did not have this problem with zot4. I checked on another computer (with the same db) and it works. So there is something wrong with my installation (any idea what could cause the problem?).
  • edited February 12, 2017
    @adomasven could you please check the debug output (The Debug ID is D590672535.)

    I can't view the debug output (the window log is also stuck, on the same way that the window suppose to show me the pdf get stuck)

    I tried:
    I uninstalled zot5 (and preferences), + clean the registry key (ccleaner)
    I rinstalled zot5 as admin, (firewall disabled)
    I launch zot5. It opened with my db inside (I did not deleted it locally)

    The problem remains:
    I can't open pdf locally
    I can't view the debug output (the window log is also stuck)

  • No, I did not have this problem with zot4. I checked on another computer (with the same db) and it works.
    You should test with Zotero 4 on this computer to make sure it is not an upgrade to Zotero 5 problem (which I am not convinced it is). If you have a backup of your original data directory - use is to test. Otherwise just back up your existing data directory and move it out of the way, so Zotero can create a fresh one. Add some items and see if you get the same broken behaviour.

    Could you also take a screenshot of the stuck window for PDFs and for the Debug Output, post it online somewhere (like dropbox or imgur) and post a link here?
  • edited February 13, 2017

    You were right, it's not related to zot5. I installed a fresh zot4 db (only on local though, I did not link it to a zot account). I then created a new entry, I inserted the local link to a pdf, and I could not open it.

    So I reinstalled zot5. Here is the screenshot of the error, with the blank windows suppose to open the pdf: http://i.imgur.com/VxgDzRy.png

    I did some test on zot5:

    + I can open native pdf (the one stored in the zotero folder/storage)

    + I can open a pdf that has been moved using zotefile to a external folder (outside zotero storage)

    + I can also open epub saved locally (the epub is opened in calibre, I only have to kill the giant white zot window on the background it also opened: see http://i.imgur.com/GotFkIo.png )

    + the problem seems to be only related to (external) pdf files (the title shown on the failed window started with:///C:/...
    I tried replacing the url by local url by :
    - .txt : it's working
    - a doc : working
    - a weblink : working

    Thanks for your help!
  • I solved it by installing the last adobe reader. I would have loved to use my adobe acrobat x pro version, but it was incompatible with zotero (on this computer)
  • just an update in case someone could use it. Adobe acrobat was badly installed, I struggle to uninstalled it on win7
Sign In or Register to comment.