[5.0 beta] 'open with' Zotero does not add pdf to library

Hi there, not sure if this should already work or if it's a feature request.
When I save a pdf file from Firefox, I can tell it to either save the file or open it with a specific program. I can tell Firefox to open the downloaded pdf with Zotero now it's a stand alone app, but the pdf doesn't get added to my Zotero library. This would eliminate a step or two when the connector/translators aren't playing nicely with a site.

Is this because when the file gets saved to the windows temp file it's a read-only file?
Only discovered that when I manually added it to an entry and then the 'rename file from parent metadata' wasn't renaming the file.

Windows 10, Firefox 51, Zotero 5.0-beta.128
  • Yeah, this just isn't implemented. I created an issue for it.
  • Hi Dan, would this also cover RIS files too? as currently 'opening with' does nothing for them either.
  • RIS files open and import into Zotero for me on Windows with the latest beta.
  • Ah, well they're not working in linux mint 18.1
    Zotero 5.0-beta.181+f3ceb7
    I can right click an RIS file, open with Zotero, the Zotero pane comes forward but nothing else happens. Not seeing any errors, ("No errors have been logged since Zotero started.") it's just not doing anything else.
  • I've changed zotero.desktop to support import via "open with" in linux. You can either wait for the next beta revision or update your local copy of zotero.desktop
  • Hi, well I did both - I tried updating zotero.desktop and that still didn't import an ris file, so I updated zotero

    [Desktop Entry]
    Exec=bash -c "$(dirname $(readlink -f %k))/zotero -url %U"

    and still no joy - still no errors, zotero just isn't doing anything at all - and I've seen the expected behaviour running zotero off my windows partition; very odd
  • As Dan explains in this post:
    The 5.0 package does include a Unity desktop file, which can be symlinked to /usr/share/applications/ or ~/.local/share/applications/ and added to the launcher from there. There's also a set_launcher_icon script that can be run first to give it the correct icon.
    You need to symlink the desktop entry into the relevant location, which I think are the same for linux mint as they are for Ubuntu.
  • Ah ha!
    I already had a symlink from
    but there was an old entry that wasn't a symlink in
    changed that, and now it works. Brilliant. Thanks for your patience and support.
Sign In or Register to comment.