My Publications PDF links on People page

I'm wondering why only some of the pdfs attached to items in "My Publications" appear on my Zotero people page (

When I moved these items into My Publications, I checked the boxes "include files" and "I created this work."

Thanks for your wonderful product.
  • It looks like there's a bug here where if you don't have file syncing via Zotero servers enabled for your personal library (i.e., file syncing for My Library is either disabled or using WebDAV), files in My Publications won't be uploaded. Is it possible that's the case for you?

    We'll fix this for the next build. Thanks for letting us know.
  • Should be fixed in build 124, available in a few minutes. I think it should upload the files automatically on the next sync, but if not let me know.
  • I'm experiencing something very similar:

    This is not linking to a PDF when I think it should. I do have attachment syncing turned off, but explicitly told My Publications to share this PDF CC-BY.

  • Just verified by turning on file syncing via Zotero. The items linked to the associated PDFs just fine, but I immediately exceeded my storage quota. I purged my file storage via the web settings, then re-tested: they no longer link.
  • Documenting another thing I tried: after disabling attachment syncing and purging my file storage in my web settings, I turned attachment syncing back on and initiated a sync. The existing PDF attachments did not sync to my library or to My Publications. I removed the existing PDF attachments, re-attached, and initiated a sync. The PDFs now appear as expected in My Publications on my profile page.
  • Yeah, there was a major change to how My Publications worked during the beta period — they're now part of My Library, instead of a separate library — so this probably stopped working then. This is actually rather complicated now, since, aside from having file syncing disabled, you could even have a file that's being synced to WebDAV but that also needs to be synced with the Zotero servers. But we'll look into this. Issue created — thanks.
Sign In or Register to comment.