[5.0 Beta] Win error 145 during operation removeEmptyDir on file

edited January 20, 2017

Yesterday, after editing some PDF documents on another computer using Zotero 4 Firefox, I tried to sync the changes to my Zotero 5 install on my other PC. However, I got this error:

[JavaScript Error: "Download request 1/TMF9KUST failed"]

[JavaScript Error: "Win error 145 during operation removeEmptyDir on file C:\Users\[...]\Zotero\storage\TMF9KUST (The directory is not empty.
)" {file: "(unknown module)" line: 0}]

version => 5.0-beta.113+2237c71, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0-beta.113+2237c71, extensions => Zotero LibreOffice Integration (3.5.12.SA.5.0-beta.113+2237c71, extension), Zotero Word for Windows Integration (3.5.6.SA.5.0-beta.113+2237c71, extension)

I first edited the file on my Zotero 5, then sync'd my Zotero 4, made some more annotations in the PDF, and now I'm back on my PC with Zotero 5 and I get the above error. Also, when I try to open the pdf in Zotero 5 it tells me that:
"The attached file could not be found.

It may have been moved or deleted outside of Zotero, or, if the file was added on another computer, it may not yet have been synced to or from zotero.org."

Which is weird since I started off making annotations on my Zotero 5 PC, and than later annotated the file on my other Zotero 4 Firefox PC.

These two issues might not be related, but I don't know for sure.
  • Can you provide a Debug ID for a sync that produces this error?
  • I think I fixed it by changing the permissions of the folder that stores the locale files from read-only. It seems to have fixed the issue. I'll fix the other issue, "attached file could not be found", by moving the file from my other PC. Consider this issue to be fixed.
  • What do you mean by "locale files"?

    If you're syncing, you shouldn't need to move files manually from another computer. See Files Not Syncing.
  • local files - basically the file in question hasn't been sync - or at least it seems so. When I try to open the PDF, I get the "The attached file could not be found." error. I know that I shouldn't have to manually move files.
  • See the link I provided.
Sign In or Register to comment.