PDF Metadata retrieve by google has a query limit?


I can retrieve about 50 PDF papers and then it seems to reach a query limit.
Popup "query limit reached. Try again later."
What is the limit?
How long I have to wait?

  • Google controls the limit and the timeout. I don't know what the limits are, but if you get blocked it may also affect your ability to access Google Scholar for a while.

    Going forward we'll be making refinements to the PDF recognition feature that should allow you to recognize more PDFs at once.
  • figured it out. google thinks too many queries means you're a bot. go to the google scholar website, and respond to the captcha to identify yourself as a real user. then it will let you run more queries.

    hope that helps.
  • Google gives me a "403 Forbidden" with seemingly no captcha made available for me to identify myself as a person not a bot. Wish I knew how long I have to wait.
  • Same thing happened to me. This is a great feature, but Zotero and Google should perhaps work together so this does not happen in the future. So far I have waited about 3 hours and still cannot access Google Scholar yet. So not only can I not search PDF metadata, I can not access Google Scholar at all. I only queried about 20 articles before this happened.
  • work around:
    I cleared all cookies from FireFox and restarted it. After the second (not the first) restart, Google Scholar came up with a captcha that I was able to fill out. Not sure why it did not do it initially.
    What a pain.
  • The following works for me (FireFox 3.0.11, Zotero 2.06b.2, Vista):

    1) Open Google Scholar (english, not local)
    2) Delete personal data
    3) Reload Google Scholar (no need to restart FF)
    4) Insert the captcha requested

    That's all
  • Amazing...that works, sort of!

    By step 2, I'm assuming you mean "delete your google scholar cookies", which you can do in FF by bringing up Tools | Options, clicking on the Privacy tab, clicking on the link "remove individual cookies", typing in "scholar", and erasing that cookie.

    I did however have to re-start FF twice, before GS would give me a capcha.
  • I too am getting blocked by scholar but nothing I do (including what dharmasrl suggests) works (I never get a captcha to respond to either). Scholar implies that the blocking is being done based on your site or network and asks for you for an IP address (single or range). However, if I run Safari from the same machine where Firefox is getting blocked, I can get to scholar without any problem. I am inclined to think that there may be some additional cookie which Google is "supplying". Anyone have any thoughts or suggestions - or should I just wait until they let me out of the penalty box ? (Mac OS X v10.6.2 FF 3.6)
  • Is there any news on how to avoid this (the thread is from 2009/2010..)? Its unfortunately still happening and the workaround is time consuming..
    Any chance to change the search engine in which the metadata is looked up?
  • this worked much better intermittently, but is back to where we once were now that google has changed it's bot detection again, and I'm afraid the person who helped with the solution last time won't be available this time around.

    Unfortunatey, there simply is no alternative to google scholar. There is no other large, cross-disciplinary full-text (that part is key) search engine.
Sign In or Register to comment.