Z5.0 export errors

edited December 6, 2016
1. [Z5.0 FFX] I selected some books in the library and tried to export them by right-button menu Export Itmes, but failed with message: An error occurred while trying to export the selected file.

I made a Debug Report: D1834134082

2. In Z5.0 standalone, I succeeded. But when I transferred the export file to another computer and tried to import it but failed with the message: The selected file is not a supported format.

I made a Debug Report: D32433845

  • Does the first error go away after a Firefox restart?

    Does the exported file have content, or is it 0 bytes? What's in it if you open it in a text editor?
  • edited December 6, 2016
    The exported file is not 0 byte.
    I can read the contents in a text editor.

    The situation is a little bit complicated.

    I use two computers: at home and at school.

    [At school]
    With Z5.0 with default data folder(C drive), I could export some items and get Exported Items.rdf.

    [At home]
    I couldn't import the Exported Items.rdf into Z5.0 with data folder in external HDD.

    In addition, when I tried to export some items, I couldn't make .rdf file, but only .html. I captured the screen.


    I use the same Zotero versions (r91).

    Please have a look.


  • edited December 6, 2016
    If you go to export an item on the home computer, do you see the full list (including Zotero RDF)?

    Are you able to export and import a single item in Zotero RDF on the home computer? If so, we'd probably need to see an example file that's failing to import, which you could email to support@zotero.org with a link to this thread or post somewhere. (You can create a small sample one that fails if you prefer.)

    Also, I'm not sure what the screenshot is meant to show — this is about Zotero RDF, not Scannable Cite (which isn't an official Zotero translator), right?
  • If you're saying that you only have Scannable Cite on your home computer, then you indeed are missing translators and should Reset Translators from the Advanced → Files and Folders pane of the Zotero preferences. I'd be interested in seeing a list of the export menu, though, if there's anything other than Scannable Cite.
  • As you said, I reset translators. As a result I could import .rdf file made on another computer, and export as .rdf file.
    But when I imported the file, importing process didn't end. I had to terminate Zotero. I captured the situation for your understanding.


    Please have a look. Thanks.
  • edited December 6, 2016
    How long have you tried letting it go? How many items should be in the file?

    We'd need to either see real-time debug output for the import or look at an example RDF file that doesn't finish, either of which you can email to support@zotero.org with a link to this thread.

    (With the debug output, you can also see for yourself whether it's still processing or whether it's stalled. If it's still processing, you would just need to let it go.)
  • edited December 7, 2016
    I made a Debug ID: D1697973710.

    I emailed my .rdf file, too.

  • This should be fixed in the latest build, though we're still doing some testing.
Sign In or Register to comment.