Juris-M standalone older version error - won't open

edited November 16, 2016
I use Juris-M standalone and firefox on two Macs - a work and home computer. The firefox version works fine, but on one Mac I'm now getting this error message when I try to open the standalone program. Any ideas?

This version of Zotero is older than the version last used with your database.

Current version:

Please upgrade to the latest version from zotero.org.
  • The links on the site were incorrect. Try reinstalling; if you still get an error, post back and I'll check again.
  • I have a similar problem. I wanted to try Juris-M for its multilanguage support, but for some reason my computer keeps showing error messages when I try to open it.

    I have Zotero 5.0.66 on MacOS 10.13.6, and the message shows:


    Do you have any idea why it won't work?
  • @yunusong: The top post in this very old thread is from a user that already had Juris-M installed and running, but was getting an error when attempting to run after an upgrade/reinstall. I assume that is not your problem.

    I can't reproduce that error. If you can provide the exact steps that lead to it -- beginning with the location from which you downloaded Jurism -- I can make another try.
  • I have been using Zotero for a very long time, so it might be that something in my system is a bit mixed up. But I would prefer not trying erasing and reinstalling Zotero.

    I downloaded Juris-M from at https://juris-m.github.io/downloads/, which I imagine would be your official site.

    Then after copying the file to the Application folder, I opened it by right clicking it, which allows me to open programs that I downloaded from non-Apple websites.

    I can see the outline of the Zotero program when I launch Juris-M, then it shows "upgrading databse" with another message at the bottom right saying

    ODF Scan: waiting for Zotero...
    Waiting for Zotero translator framework to initialize...

    Then the above message appears with two options, Quit or Check for Update,
    If I click the latter, it will check for updates, which results in a message that there is no further update available, then I can only quit the program.

    I tried removing the Chrome plugin, but nothing has changed.
  • edited May 27, 2019
    Okay, those would be the normal steps for installing and running the program. I'll need to try harder at reproducing the fault. The Mac OS machine is at work, I'll try again tomorrow.

    Meanwhile just one more question, to confirm. Zotero is not running when you attempt to run Jurism? (it should not be, and if it is, Jurism should refuse to run, with a message that Zotero is already running)
  • Ah. Two further questions to get ready for more testing tomorrow. First, in Zotero, when you do Preferences -> Advanced -> Files and Folders, where is your Zotero data folder located -- in the default localtion, or in a custom location? Second, are you running Zotero (and Jurism) with a non-English interface?
  • To answer your questions:
    1. Yes, I did see the message that Zotero is already runing. The error message from Juris-M appears when I try to lauch it with Zotero not running.
    2. My data folder is set to the default location
    3. My interface is English

    One thing that I am not using with the default setting is the File Sync. I sync my attachements to Box.com. Could this be causing the problem?
  • Thanks, I'll play with that setting too.

    One other question that might be relevant: which plugins do you have installed, and what are their versions?
  • En route to the office now, but one more q that might be dispositive. In your Zotero folder, do you find files "jurism.sqlite" and "abbrevs-filter.sqlite"? (if so, rename them and try running Jurism again)
  • Pending confirmation, it looks like the intuition immediately above was correct: I've been able to reproduce the error by setting the database schema version to that used in the Jurism 4.0 series. You should be able to recover by renaming those two files. On the next run, Jurism will create an empty database, which you can sync to the same zotero.org account as Zotero proper.

    (Jurism 5.0 should be attempting to handle this more gracefully, but if there is not data in the old install of Jurism, the above steps will avoid the error. If you need to recover data from the older database, post back and I can help with the steps for that.)
  • edited November 1, 2020
    Hello there,
    I just wanted to say that I have the same problem and tried renaming those two files from "jurism.sqlite" and "abbrevs-filter.sqlite" to "rename1" and "rename2" consecutively. This hasn't worked. I should state, however that I have got juris-m and all related folders (including storage) saved to a cloud service on my computer; onedrive. This is because I need the attachments of each entry to be stored on onedrive for what I am using it for. It has worked fine - stored on the cloud - for over half a year now but it, all of a sudden, began giving me the above error and problem, without me making any changes to Juris-m. Could it be because of some updates in juris-m? Any help, please, will be appreciated. Thank you in advance.
  • edited November 1, 2020
    Hi. Just uninstalled and re-installed Juris-M in the same location but still getting the following messages (with two options: to either check for updates or quite with neither button working. A little worried now because I was hoping to create a bibliography of my work thus far tomorrow):

    XML Parsing Error: undefined entity
    Location: chrome://zotero/content/standalone/standalone.xul
    Line Number 44, Column 1: file:///C:/Users/sengn/OneDrive%20-%20Anglia%20Ruskin%20University/+1%20PhD%205%20Final%20thesis/2%20PhD%206%20Reading/Juris-M/extensions/abbrevs-filter@juris-m.github.io/bootstrap.js:56:14
    observe@resource://gre/modules/addons/XPIProvider.jsm -> file:///C:/Users/sengn/OneDrive%20-%20Anglia%20Ruskin%20University/+1%20PhD%205%20Final%20thesis/2%20PhD%206%20Reading/Juris-M/extensions/abbrevs-filter@juris-m.github.io/bootstrap.js:241:3
  • edited November 1, 2020
    Hi. Further update:
    Just in case the problem was as a result of saving Juris-M on a cloud, I reinstalled it outside of the cloud. However, I am getting the same error message.
  • I should state, however that I have got juris-m and all related folders (including storage) saved to a cloud service on my computer; onedrive.
    If "all related folders" includes the sqlite files, they might have gotten corrupted. The sqlite files must not be synced using onedrive/Dropbox/etc.The storage folder can safely be synced using onedrive/etc.
  • Thank you emilianoeheyns. Your advice resolved the issue.
Sign In or Register to comment.