OpenSearch engines with application/xml

I tried to create an OpenSearch engine and everything worked fine on my test page, i.e. I could add the LookUp engine in Zotero. However, for the productive site this does not work anymore, i.e. after clicking on adding the lookup engine, it fails quietly.

The two links and xml websites are IMO identical. The only difference I could see, was that once page was delivered as text/xml and once as application/xml. Could this cause a difference in Zotero? Fixable? Any other ideas what is going on?
  • Looking at this with HttpFox, Zotero struggles with the relative link (i.e. it looks like it doesn't know on which host it is). If I download the page (Firefox completes relative links on saving) and run it locally, it works. I'd bet that using href="" as the rel="search" link works.
  • Yes, indeed. Changed to an absolute link and it works! Thank you very much!

    Dan: It would be nice if Zotero can also handle relative path in OpenSearch links.
Sign In or Register to comment.