After Zotero-related crash, LibreOffice restores 3-hour-old document


This problem has been dogging me for several years, and I'm not sure whether it's a Zotero or LibreOffice bug.

Today I've been working on my book manuscript and I went to insert a Zotero citation and got the communication error dialogue telling me to make sure Zotero was open (I had forgotten to open it). LibreOffice froze for several minutes and there was no way to close the dialogue or interact with LibreOffice. So I force quit, thinking the worst that could happen is that a 2-minute-old backup file would be restored (yes, I'm paranoid about losing my work and have it set to back up every 2 minutes). But when I reopened LibreOffice, I found that it restored the 3-hour-old file I had manually saved. So I just lost 3 hours of work.

I seem to recall reporting this to LibreOffice a few years ago and the developers wouldn't believe me because they were sure autosave worked.

Any idea what might be going on with that? Could this be Zotero-related? It seems only to happen with Zotero-related crashes.


  • Well, I'll believe pretty much any horror story about LibreOffice or Word :(.

    I don't see how Zotero could cause this -- it just inserts reference marks in the file and otherwise doesn't do anything with LibreOffice. It could cause the freezing (although it shouldn't, and it doesn't really do anything that should cause that), but I can absolutely not see how it would at all affect auto save.
  • Yes, that's what I figured. It would be nice if someone could figure out how to make Zotero generate an error dialog without freezing LibreOffice. I wonder if it has to do with different, incompatible versions of java. But it's hard to imagine how Zotero could affect autosave. Thanks.
  • For what it's worth, the freeze seems mostly to happen with large documents with lots of references (book manuscripts). I just tried creating a smaller test document to see if I could reproduce the issue and it works as intended.
Sign In or Register to comment.