How to get rid of the full stop in the reference

Zotero, Style Chicago Manual Full Note or SBL Full note automatically puts a period at the end of each reference. However, often, in a footnote, I do not want a period but go on with my sentence. For example, I get: Alan Appelbaum, The Rabbis' King Parables, 24., has said.... Obviously I do not want a period after 24. How can I change the style so that I avoid this double punctuation?
  • the recommended way to handle this is to put commentary on notes in the suffix/prefix field of the citation. https://www.zotero.org/support/word_processor_plugin_usage#inserting_and_editing_citations

    If you do want to edit the style, you'd remove suffix="." from
    <layout suffix="." delimiter="; ">.
    See here for general instructions: https://www.zotero.org/support/dev/citation_styles/style_editing_step-by-step
  • Dear Adam, if I try your first solution, I can indeed add a comma, but I cannot remove the period. I get a reference like: ... Title., says.... The period remains. Is my only choice to change the style?
  • This thread and others like it are so important and remain unresolved. I need to remove final punctuation in about every other citation--e.g., "Informational footnote text (Author, Title, Page)." With Zotero as it is, this becomes "(Author, Title, Page.)."--two periods in a row. I've tried a closing parenthesis in the suffix box, but for some reason Zotero turns it to a bracket--and a bracket is also a bracket. By the time I am finished manually overriding Zotero in a whole monograph (Society for Biblical Literature style, similar to Chicago style), much of the document cannot be updated. I see multiple threads about requests for an option to remove final punctuation, but they date years back, and there still seems to be no such option. Is this likely to be an option in the future? Or am I missing something that would work around this? Thanks much!!
  • Why am I getting a period at the end of the note? Sarah Handley-Cousins, Bodies in Blue: Disability in the Civil War North (Athens, GA: The University of Georgia Press, 2019). I do change the period to a comma once I put in the pages.
  • Sorry, I'm not quite sure what you're asking -- you're getting a period at the end of a Chicago style note because Chicago says to put a period at the end of the note.

    If you want to add specific page numbers to a citation see https://www.zotero.org/support/word_processor_plugin_usage#customizing_cites and that will handle comma and period correctly.
  • Hi, as I said, if the reference is part of a loger sentence in a footnote. You don’t want a full stop in the middle of the sentence.
  • Sorry, that question was for Rick/K.

    For your case, if you put something like ", says a lot more stuff to explain the citation." into the suffix field, you'll get
    Teugels, Title, says a lot more stuff to explain the citation.
    i.e. the period at the end of the sentence where it belongs, not after the reference.
  • Lieve Teugels, for what it's worth, I have solved some of my problems--those involving shortened form (subsequent) references--by putting the reference in parentheses and adding the closing parenthesis to the page numbers field. Sometimes this means including the author's last name in the sentence and excluding it from the citation. Here is one example using your book from your 2016 comment: "Alan Appelbaum has said XYZ" (Rabbis' King-Parables, 24). In this case, the page numbers field says "24)" and I checked "Omit Author."

    You can also add a parenthetical citation to the beginning or middle of a sentence if you combine this solution with adamsmith's first solution from 10/3/16 above.
  • edited 8 days ago
    Could I ask how to input .csl code with < > ?

    E.g. if there is layout suffix="." delimiter="; " between < and > , the code does not show.

    How to input .csl code in this forum properly please?

    Such as the code in the comment from :
    adamsmith October 3, 2016

    above.
  • Put it between <code> </code>
  • Thanks a lot !
Sign In or Register to comment.