RTF/ODF-Scan Problem: Unable to specify input/output files.

In the standalone app for Mac, I click Tool>RTF Scan...

A dialogue box opens. There are fields for input and output files with buttons to "select file." I click on select file and nothing happens.

I try to type the filepath in the fields and it won't let me.

I have tried reinstalling the tool, reinstalling the standalone application. I am using Yosemite.

Thanks for any help.
  • My error report is: 1578650746
  • edited September 5, 2016
    [JavaScript Error: "ReferenceError: Zotero_RTFScan is not defined" {file: "chrome://rtf-odf-scan-for-zotero/content/rtfScan.xul" line: 1}]
    Just to clarify, you're using the third-party RTF/ODF scan plugin, so this question isn't about Zotero proper (which has a different "RTF Scan" feature). The developers of that tool might be by to help, though. I've edited the thread title to make it clear what this is about.
  • edited September 5, 2016
    Oh right. Thanks for the clarification. I deleted the add-on and now I can specify the files using the standalone. But now the output file is corrupt and cannot be opened. alas, i'll keep working on it.
  • Hi, I am also having the same problem as tdenmead. Dan, could you provide a link to where we would inquire from the third party. Or if anyone already knows the answer, perhaps they could post here.

  • Apologies, the update process appears broken. You'll need to re-install the add-on from here:
  • Adam, Thanks! That did it! And the less than 2-min response time was much appreciated!
  • A very important detail: It's necessary to remove the old add-on first. If you just re-install the update over the old one, it does not work. Hours to figure it out! Thanks to all for sharing here!!!
  • Adam's github link is for firefox - is there anything that works on the standalone Zotero?
  • The same plugin works for both.
  • @Pia Montealegre: A late response here, but I've added a note on the site, indicating the need to remove old versions of the plugin.
  • I've installed the new add on and now zotero is stalling at the Formatting Citations stage. Any clue?
  • We'd need a lot more info. What are you referring to as the "formatting citations" stage? What setup (Word processor where you create the ODF, LibreOffice/OpenOffice version, Zotero version? Is this one specific document or does it also happen in a simplified test document?
  • adamsmith - Thank you so so much for your continued support of this product! I also am having the same problem. It worked great in the past, but now the rtf/odt scan extension for zotero has quit working for me :( And I only have one week before I need to submit a final copy of my thesis to my professor. Zotero has been a terrific help organizing my references! Now I need to convert my citations to American Anthropological Association format. Please advise.

    Here's my info:
    2009 Macbook Pro 13"
    El Capitan osx 10.11.6
    Scrivener v. 2.8
    OpenOffice v. 4.1.2
    Zotero v. (stand alone)
    RFT/ODF Scan for Zotero 1.0.23

    I tried running the odt scan on a simplified test document, like you suggested above, but the RFT/ODF Scan still wouldn't work. It won't work on any file because the dialog box won't let you select ANYTHING for a source file. Just nothing happens when you click on "Choose File..." And it won't let you type the path in manually :P
    The only think it will let you do it change between RFT, ODF to citations, and ODF to markers, nothing more.

    I have tried removing the RFT/ODF Scan for Zotero in the stand alone version of Zotero. Then I downloaded and reinstalled the latest RFT/ODF Scan for Zotero 1.0.23. But this still hasn't fixed the problem. Any ideas?

    Many thanks!
  • https://forums.zotero.org/discussion/comment/261278/#Comment_261278

    (note that that is the official support thread -- also linked from the project page)
  • Thanks adamsmith! I'll take a look over there.
  • I found the info I needed, thanks so much adamsmith!! :)
  • RFT/ODF Scan is the best thing since sliced bread. Thank you for building it and for your support!

    The plugin offered here does not work (file path not available in Zotero): https://zotero-odf-scan.github.io/zotero-odf-scan/

    It should be: https://github.com/Juris-M/zotero-odf-scan-plugin/releases/latest

  • I fixed the links. Sorry for taking so long.
Sign In or Register to comment.