Zotero experienced an error updating your document

Report ID: 1433418675
error suddenly appeared yesterday
'Zotero experienced an error updating your document'
'field is undefined'
[JavaScript Error: "TypeError: this._editor is undefined" {file: "chrome://zotero/content/bindings/styled-textbox.xml" line: 217}]
followed troubleshooting guide but error continues
duped doc, got rid of possible problem citations, even started completely new doc unrelated to original ... error persists.
what is interesting is that when doc is duped then error will go away for first citation, then return.
using version standalone Chrome
I notice there are other discussions on possibily related topics but I am starting a new topic just in case this is unrelated

UPDATE: using Zotero on Firefox, several citations were added and updated OK and then the error began to appear again. I reinstalled Zotero, Word plugin etc etc still having error.

[JavaScript Error: "Invalid or missing translator metadata JSON object in ReferBibIX.js" {file: "file:///Users/xxx/Library/Application%20Support/Firefox/Profiles/uersqrfb.default/zotero/translators/ReferBibIX.js" line: 0}]

What is this:

Handler.prototype.process@Promise-backend.js:937:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:816:7 < this.PromiseWalker.scheduleWalkerLoop/<@Promise-backend.js:750:11

What is PromiseWalker ??
  • @Dan -- could you look in the error report? Anything of note? Because of the missing translator metadata, I'm thinking there might be some sort of corruption, but maybe something else going on that I'm missing.

    @opacct -- PromiseWalker is a javascript library. I don't believe it's used by Zotero, but may be used by Firefox or another add-on. Zotero's error reports sometimes pick up other things.
  • edited August 18, 2016
    I went completely through the Debugging routine at https://www.zotero.org/support/word_processor_plugin_troubleshooting#debugging_broken_documents when I originally noticed the errors on Zotero - to no effect.
    [I should qualify that ... the debugging did lead me to understand that the errors may be inherent in the doc itself, especially since they reappear in Juris-M, and because creating a completely new doc in Juris-M seems to rid the problem more or less]
    I switched over to Juris-M as I have a deadline and half my project is not functioning per citations on Zotero. I thought: nothing to lose, and so I installed Juris-M and started the next part on a completely new doc. No issues. Then I grafted the sections from the original doc into the begining of the new doc, and yesterday that worked fine on Juris-M, even though some footnote formatting (colours) carried over and would not respond to changes. Today, when I opened that doc, I came across the same errors as with Zotero. Now I am using the new doc (without the original part) and completing that, and at the end I will stick on the new part before submission. I will also submit an error report for you regarding the Juris-M issue for the combination doc.
    Today's errors on Juris-M:
    [JavaScript Error: "TypeError: can't access dead object" {file: "chrome://zotero/content/xpcom/fulltext.js" line: 515}]
    [JavaScript Error: "field is undefined" {file: "chrome://zotero/content/xpcom/integration.js" line: 1616}]
    [JavaScript Error: "field is undefined" {file: "chrome://zotero/content/xpcom/integration.js" line: 1616}]
    [JavaScript Error: "field is undefined" {file: "chrome://zotero/content/xpcom/integration.js" line: 1616}]

    I tried to submit the error report but Juris-M is giving me 'Invalid response from repository'
  • edited August 18, 2016
    (Note that Juris-M isn't a Zotero project, so the "you" doesn't apply here, though the developer, fbennett, is also in these forums.)
Sign In or Register to comment.