Very Slow Zotero with Word 2016

Hello wise and helpful Zotero experts (and thanks in advance for any help),

I've been using Zotero for some time with Word 2016 and have never experienced problems. For the past few days or so, though, it has been extremely slow. I'm not quite sure how best to explain the problem other than that (but can respond to specific questions), but do have a debug ID: D1530808861, which I hope gives more helpful information.

Does anybody have any possible solutions? I've tried restarting etc. but with no success.

Many thanks again!
  • How long a document are we talking about and with (roughly) how many Zotero citations?
    And is this on Windows or Mac?
  • The wordcount is circa 12k, with (as a guess) 40-50 citations. Perhaps also relevant is that some of the elements of the doc have been merged from previous docs, including part of one that was done with a different ref manager. I did try on a blank document though, and the problem was there too, so I'm not sure (but don't know) if it's the document itself. Although perhaps having others open slows it down, I'm not sure.

    And, it's a Mac running Word 2016. Zotero claims I don't have the plugin for word installed, which seems impossible to me (I have the toolbar and have added things many times), unless this is an issue with the standalone widgit. I remember having to figure this out when getting the new version of Word, but couldn't tell you what I actually did now!

    Many thanks for your help, as ever.
  • Yeah, that's definitely not normal. Don't worry about the "no installed" thing -- that doesn't always show correctly.

    Could you provide a debug ID that covers some regular action like inserting a citation, please?
  • The ID I listed above was while trying to add a citation (that was yesterday, and it still hasn't completed it). I'll quit zotero and word and try again, both in a blank doc and the one I'm working on. Hopefully that helps narrow the problem down.
  • oops, sorry, I overlooked that. Another one from a blank doc may still help, but
    @Dan -- could you check this out, please?
  • Yeah, I'm pretty sure that's not slow, just broken:
    [JavaScript Error: "NS_ERROR_FAILURE: Document modified during update @[setCode:field.m:585]" {file: "file:///Applications/" line: 211}]

    [JavaScript Error: "Document modified during update @[setCode:field.m:585]" {file: "file:///Applications/" line: 211}]

    [JavaScript Error: "TypeError: temp is null" {file: "chrome://global/content/bindings/preferences.xml" line: 1215}]

    [JavaScript Error: "uncaught exception: ExceptionAlreadyDisplayed" {file: "resource://zotero-macword-integration/installer.jsm" line: 67}]

    [JavaScript Error: "NS_ERROR_XPC_BAD_CONVERT_JS: Could not convert JavaScript argument arg 0 [nsIObserver.observe]" {file: "file:///Applications/" line: 403}]

    version =>, platform => MacIntel, oscpu => Intel Mac OS X 10.11, locale => en-US, appName => Zotero, appVersion =>


    (3)(+0042848): Integration: Request already in progress; not executing MacWord2016 addCitation

    (3)(+0554730): Integration: Request already in progress; not executing MacWord2016 addCitation
    adamsmith might have other ideas, but restarting Zotero and Word would definitely be the first thing to try here, as would trying in a new document.
  • Yep, I quit all apps, made the latest update to word, restarted the computer, tried again. It's now very slightly better (in the sense that it actually makes a citation) but is still very very slow.

    I also tried in a new doc, which seems to be working ok. If need be I can just do the citations and bibliography there and cut and past them over, but for obvious reasons it would be better to do them directly if this is something resolvable.

    I should also add that the doc has locked track change settings, if that might make a difference.

    Thanks again!

    Debug ID: D1117533137
  • Integration: Retrieved 29 fields in 38.358; 0.7560352468846134 fields/second
    Yikes. Yeah, that wouldn't really be usable.

    I'm not sure what it would be, but this seems like something specific to that document. Maybe adamsmith has an idea.
  • I should also add that the doc has locked track change settings, if that might make a difference.
    I'm not sure I understand this (locked settings? You can't change them? Is that possible?) but if you can disable track changes and accept all changes -- in a copy of the document for testing -- that would be one thing to try.

    Also, what citation style and do you have a bibliography inserted?
Sign In or Register to comment.