et-al-min no more read?


i am wondering if the et-al-min like settings in the csl files are disregarded by some way or reason...

i have this in the csl file:

<option name="et-al-min" value="3"/>
<option name="et-al-use-first" value="1"/>
<option name="et-al-subsequent-min" value="3"/>
<option name="et-al-subsequent-use-first" value="1"/>
<option name="disambiguate-add-year-suffix" value="true"/>
<option name="disambiguate-add-names" value="false"/>
<option name="disambiguate-add-givenname" value="false"/>
<option name="collapse" value="year"/>

however, i get for example
(Heinemann, Kiffmeyer, Stützer, Hadtstein, 2008: S. 224)
which shows all 4 authors... as far as i understood, it should only show the first author and then



btw: firefox 3, mac 10.5, neooffice 3pre
  • Have you confirmed that your file is valid?
  • yes, and it even happens with the standard style like
    Harvard Reference format 1 (Author-Date)

    so i deleted the styles i used, restarted firefox and neooffice, made a new document to insert and test some citations. i got:

    (Heinemann, Kiffmeyer, Stützer & Hadtstein 2008)

    (Heinemann, Kiffmeyer, Stützer, Hadtstein, Türk u. a. 2008)

    (Agouridas u. a. 2008)

    (Eppinger u. a. 1994)

    (Butterwegge u. a. 2008)

    (Holleman u. a. 1995)

    !! Interesting note: after having added the first citation, it showed correctly
    (Heinemann u. a. 2008)
    but then, after having inserted the 2nd citation, it showed all names. The second item in the database was made as a duplicate of the first one, and then title was changed, authors were added.
    THat seems to be the point! It does not happen until i insert this citation which was made as a duplicate.
    If i insert "any" (as far as i can judge) other item for citation, author names are still being displayed correctly.

  • edited March 14, 2009
    What happens if you remove the following lines?:

    <option name="disambiguate-add-names" value="false"/>
    <option name="disambiguate-add-givenname" value="false"/>

    It might be related to:
  • edited March 14, 2009
    That's it. thanks!
    it seems that these 2 entries should not be there, then i get
    (Heinemann u. a., 2008a)

    (Heinemann u. a., 2008b)

    So having them set to true or false, the behavior described above does happen.

    Maybe it's a kind of priority/order of deciding what to do? if the first xxx authors and the year are the same, the zotero seems to think its better to show more names instead of disambiguating the year..

    thanks!, greetings
  • The Zotero code seems to be a bit buggy here. Any value of disambiguate add-year-suffix, disambiguate-add-names or disambiguate-add-givenname except an empty string "" will activate these disambiguation options.
Sign In or Register to comment.