Group and personal library rejoining after edits

I think I am heading for a problem. Is there an easy way to rescue me?

I have a personal library of about 550 items. I'm working on standalone. I took on an assistant for a project which deals with just a subset of my main library. So I created a Group library, shared it with my assistant and dragged 50 relevant items into it. We have both continued to work on updating both libraries (I can't stop working on everything while the side project is running). I know about Zotero's duplicate management and it has always worked well in the past. So I thought that at the end of the project, I could drag everything back from the Group library into my main library. I would view each duplicate and merge them - I wouldn't mind checking manually if any fundamental details flagged as changed - but all the tags, attachments and notes would merge, or new records would be created if there was a completely new item in the Group library.

However, I think I have misunderstood, because I can't drag anything back into my library to create a duplicate. Nothing happens. Only if the item is completely new will it move from Group to main.

Am I going to have to do a manual merge at the end of the project (ouch!)? What should I have done instead in this situation? I feel I am missing something obvious that I should have done. Thanks for help and advice!

(... A detailed example in case the situation is not clear from above:

In my main library, I have an item (Smith, 2000) with a tag, A. This was copied into the Group library at the beginning of the project. During my own research, I add an extra tag, B, and a file to Smith. In the Group library, my assistant has added a tag C. She also spotted that the publication year was in fact 2001 and adds a note to explain that.

What I expected: I drag Smith from the Group library into the main library, creating a duplicate, which I can then merge into a single record, with three tags (A,B,C), a note and a file. I expect to see an icon indicating that I have to choose 2000 or 2001. Since I have the note to help me, this is not a problem. I choose the updated year and merge. Result is (Smith, 2001) with A, B, C, file, & note.

What actually happens: I drag Smith from the Group library into the main library. Nothing happens. Smith is still 2000, A, B, file. No duplicate with 2001, C, and note is created, and the duplicate tool therefore doesn't work.

What I've tried: I've tried dragging into a separate subfolder. There, the item is created, but only in the main library form (Smith, 2000) with A, B and file, not in the Group form. I've tried duplicating the Group item, then dragging to main library fresh subfolder. This partially works - I can merge duplicates - but it only works for tags and details, not for attachments and notes. The files have to be dragged externally and then reattached, the note content has to be manually copied and pasted. Yuk. But it's better than nothing. ...)
  • Quick version of what's going on:
    Items dragged between different libraries (i.e. usually a group and da personal library) remain connected in the database and cannot be duplicated by dragging them back. There is a rational here (one wouldn't want duplicates to accumulate this way) but no one thinks the status quo is satisfactory -- I can't tell you when the planned improvements (some version of a merge dialog/automated merging) will happen.

    As a workaround, have your RA export to ZOtero RDF, import into your library, then merge the duplicates.
  • That RDF export/import works perfectly. Thanks so much.
Sign In or Register to comment.