macOS Sierra: papers protected?

  • edited March 24, 2017
    You have to hold down Option when clicking the Go menu to get to ~/Library. (It's easier to just move the folder, though. No need to copy.)

    Also a good idea to use ~/Zotero with a capital Z as the destination, which will match what 5.0 uses by default (though whatever you have set as a custom location will still work).
  • thanks dstillman!
  • I have the same problems since I upgraded to Sierra on my Macbook pro, did someone find a solution ?
  • The solution(s) are listed in this thread, see e.g. Dan's post here:
  • Zotero 5.0, now available, will automatically migrate your existing data directory out of Application Support and into a "Zotero" directory in your home directory, which should fix this issue. If you're running Zotero 4.0 for Firefox, you should first install the new Zotero Connector for Firefox before running Zotero 5.0 to allow the migration to take place.

    (If you've already chosen a custom data directory, Zotero 5.0 won't move it.)
  • Hi all,

    I've upgraded to 5.0.8 and only in the last couple of days have I had issues saving annotations/highlights on pdf's. I get the same 'the original document can't be changed, so a duplicate with your changes has been created.'

    I checked the location of my library and it is in the default location- the zotero folder.

    Any help would be gratefully appreciated!
  • @aarontimo: What's the exact location of your data directory in the Advanced → Files and Folders pane of the Zotero preferences? (You can x out your username if you want.)
  • @aarontimo
    Any chance you've left Preview open for a while? I, too, sometimes get this error, and I've found that quitting Preview and/or restarting my Mac rectifies the issue.
  • Thanks @dstillman. The exact location of the default library is /Users/AaronsMBP/Zotero. My library was previously in the custom location '/Users/AaronsMBP/zotero', so having read the posts here I changed to the default location (hoping that would fix it) and capitalised the title of the zotero folder. But the error was still there.
  • edited August 8, 2017
    And if you do Show File on a file for which this is happening, you end up in /Users/AaronsMBP/Zotero/storage/<random 8-character folder>? Or somewhere else? As far as I know this only happens for files within the Library folder, so if your data directory is just in your home directory something else is going on.
  • Yes, that's right @danstillman - the file is in /Users/AaronsMBP/Zotero/storage/.

    Thanks for the suggestion @abodywithoutorgans. Always worth trying, but that didn't work either.

    I starting to wonder whether it has something to do with pdf itself. The file was a 'print to pdf' from an ebook, so maybe there are some copyright protections in place. Although, this isn't the first time in the last few days this has happened. I just can't remember what the other file is.

    I just tried another file, which already had some highlighting saved on it, and it worked fine. So maybe it is the file?
  • I just OCR'd the file using Readeris and the annotations are saving correctly - thankfully! Must have been a permissions/copyright protection thing...
Sign In or Register to comment.