File sync error - javascript error: "no element found"

Every time I sync my Zotero lately I get a file sync error. This error occurs even after I restart Zotero or restart my computer.

I would report the error with an ID number, but when I go to report the error I get another error: 'Invalid response from the repository'.

Here is the error message I receive:

[JavaScript Error: "A file sync error occurred. Please try syncing again.

If you receive this message repeatedly, restart Zotero and/or your computer and try again. If you continue to receive the message, submit an error report and post the Report ID to a new thread in the Zotero Forums." {file: "chrome://zotero/content/xpcom/storage.js" line: 404}]

[JavaScript Error: "no element found" {file: "https://JoshCraig:********" line: 1}]

[JavaScript Error: "no element found" {file: "https://JoshCraig:********" line: 1}]

Is there anyway I can fix this?

Is it possible to at least identify the offending files and delete them?
  • edited July 13, 2016
    Are you still seeing this? Good chance this was just a brief server glitch.
  • Yes. I just closed Zotero, re-opened and synced again and I still get the error. For the record, I'm using Zotero Standalone v4.0.20.
  • Zotero 4.0.20 is over two years old. If you really mean that, you should upgrade to the latest version from the download page.
  • And I still get the same error message when I try to report it.
  • Yes, my IT department tells me Zotero updates are difficult to push out so we don't update regularly. I'll try it at home with the latest version and see if things are different.
  • Well, the latest version may or may not help, but if not this would be an issue with your network or computer security/firewall/proxy settings, so you'd likely need to enlist the help of your IT department either way.

    As a start, you could check if you have a normal connection to various Zotero domains:

    You'd want to check,, and
  • OK thanks I'll give it a shot and let you know how I go.
  • Connection seems normal. I get a green padlock issued by RapidSSL in all three cases.
  • If you generate debug output for trying to submit an error report (assuming it still fails), click View, and paste the output into an email to with a link to this thread, we can take a look. Something is preventing Standalone from making normal network requests. (Both syncing and error report submissions should work, and it's simpler to look at the latter.)
  • I've sent the debug output through. Thanks.
  • I'm afraid that just shows your network requests being interrupted. That's also still with 4.0.20. We can't provide any support for a version that old, so you'll need to upgrade before doing anything else.
  • No worries, understandable. I'll return to this thread when we eventually upgrade.
Sign In or Register to comment.