Unexpected status code 401 in zotero.sync.storage.getstoragemodificationtime

After a sync I get this error on my primary machine. I haven't still tried a sync on a secondary computer.
I'm using the latest zotero, Iceweasel/Debian, and mydisk.se for the synchronization.

It seems not a danger for my collection, but how can I get rid of this alarm?
I'm not sure the synchronization was successful...

(Report ID 1096624204)
  • I'm having the same error today, started yesterday, on both PC's. Would appreciate help, thanks.
    Caleb (Using FF3, Zotero 1.5b1)
  • The primary machine is able to sync only the metadata but not the attachments (pdf files and snapshots of pubmed); the secondary pc sync the metadata but doesn't find the attachments.
    So my files are only on the primary pc and are not synced with the online repository and the secondary machine.

    Have I try to reset remote repository and resync with local?
  • Same problem (sync error) syncing data + attachments.
    Zotero 2.0b4
    Firefox Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/2009042708 Fedora/3.0.10-1.fc9 Firefox/3.0.10 .

    Error message:
    [JavaScript Error: "[Exception... "'Unexpected status code 0 in Zotero.Sync.Storage.getStorageModificationTime()' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]

    Report ID: 849321243

    Does anyone know of a solution?
  • edited June 3, 2009
    What WebDAV server/service are you using?
  • edited June 3, 2009
    I am using webdav in my own linux server with apache httpd-2.2.11-2.fc10.i386 through mod_ssl-2.2.11-2.

    Strangely enough, after getting the error repeatedly for the last five days and five times this morning while testing, when I added my post I clicked on the sync button again and it synced without an error. It has been syncing normally since (tried about 10 times).
  • edited June 3, 2009
    The error described above seems to have been caused by an update to the ssl certificate of the webdav server where the attachments were stored. When accessing the site with Firefox, a cautionary screen comes up stating that the website's ssl certificate is self-signed. Adding an exception in Firefox to accept the self-signed ssl certificate cleared the access to the website, and coincided with the disappearance of the error in Zotero syncs.
  • I have the same error (error report 140880727). I am using Box.net, zotero 2.0b5, and FF 3.0.11 on XP. In this case, I have just added a file using "Store Copy of File".

    In the error log, there is always a pair of errors each time I try to sync: first, one that says
    [JavaScript Error: "entry is null" {file: "chrome://zotero/content/xpcom
    /storage.js" line: 2953}]
    This is followed immediately by the 401 error:
    [JavaScript Error: "[Exception... "'Unexpected status code 401 in 
    Zotero.Sync.Storage.getStorageModificationTime()' when calling method:
    [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e
    (NS_ERROR_XPC_JS_THREW_STRING)" location: "" data: no]"]
  • continuing my prior post.. I forgot to mention that I tried to follow mgpapp's advice, and I went to Box.net/dav in my browser. But The certificate had'nt expired and my login worked fine, and this did not clear up the sync problem in zotero.
  • I'm having the same problem. My error console reports: Error: [Exception... "'Unexpected status code 0 in Zotero.Sync.Storage.getStorageModificationTime()' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

    I am running my own WebDAV server, and the certificate has not expired. It appears that both metadata and files are syncing even though the error is being thrown.

    Suffice to say it worries me, and I don't want to risk losing data.
  • Having same problem. I have added the exception to Firefox for the ssl certificate but zotero still won't sync.
  • Just in case someone else is as distracted as me... Just fixed by adjusting windows clock to the right date and time, and remove time conflict with ssl certificate.
  • Perhaps it is a clock issue...

    I was having the same problem (and it was not syncing, the error seemed to block it) and after reading pturenne's comment above, I thought to see if the problem was a time zone difference between my computer and the my WebDAV service provider. I uploaded a file to the server and noticed that the time stamp was off by about 30 minutes (e.g., their clock seems to be incorrect). I changed my computer time to align with what appears to be their time and then it synced no problem.
  • edited July 25, 2009
    report ID: 712999129. I get the error: Unexpected status code 401 zotero.sync.storage, the same as above. it seems I am able to download what I have done on other computers (pc and mac) but am not able to upload from the machine with the error.

    firefox 3.5.1, mac, leopard and zotero 2.0b6.3.
  • If you're getting the 401 error, please indicate what WebDAV server/service you're using.

    If you're getting the 0 error, it's likely a problem with your WebDAV server's SSL certificate, and you should be able to see the problem by loading the WebDAV URL in the browser.
  • I just tried to put add a new computer to my zotero account. I think I accidentally interrupted its initial sync, but now I'm getting the same 401 error from all computers when I try to sync and the new one freezes up. I'm using drop.box for a webdav server
  • edited July 26, 2009
    >> If you're getting the 401 error, please indicate what WebDAV server/service you're using.

    i'm using box.net, firefox 3.5.1, mac, leopard and zotero 2.0b6.3.

    The file names for my attachments are being retained across computers but not the attachments themselves.

    Many thanks
  • I'm using drop.box for a webdav server
    Do you mean box.net? Dropbox is a different kind of service and as far as I know doesn't provide a WebDAV server.

    As far as I can tell, all the 0 errors were due to SSL certificate problems, and all the 401 errors are happening on box.net. We can probably get a box.net account to test this, but, if anyone not on box.net is getting a 401 error, it'd be helpful to know.
  • I'm getting the same 401 error.
    I'm using box.net, firefox 3.5.1, vista, and zotero 2.0b6.3
  • The same here:
    401 error
    Using box.net, firefox 3.5.1, XP, zotero 2.0b6.3

    It is also very hard to login at http://box.net/dav using my box.net credentials (needs at least 5 login attempts, after that, 5 login attempts to enter a folder/navigate around on the box.net/dav). In te sync-preference pane, zotero also indicates that folder sync is not possible ("Did not accept username and password entered, blabla"). However, normal login at box.net is possible.
  • edited July 28, 2009
    Ok seems to be fixed now. I can also login at box.net/dav, so probably a problem at the side of Box.net? Although this could recur of cource. Has zotero also contacted box.net about the problem?
  • I have been receiving the same status code 401 error for several weeks now (and also can't access attachments. I am using the WebDav server provided by my university. I can't find documentation on what exactly they are using, but this is the address for my service (without my personal info on the end of the URL):
  • This just happened to me as well.

    This is a bug in Zotero or, at least, the error message is. Basically, if the SSL certificates are not valid (e.g., they are expired or have changed), Firefox will refuse to connect until the user adds an exception. This is the normal behavior you have run into while browsing around. Instead of being taken to the page, they are brought to a special warning page.

    Apparently, this is happening to Zotero, but it doesn't know enough to understand what is going on. Zotero seems to respond by throwing up this error about modification times. There is no issue with modification times in the examples of all the people who have posted here.

    Users can work around this by pointing their browser at their WebDAV URL by hand and then clicking on the necessary pieces to add this exception.

    I'm not sure what the correct behavior for Zotero is. Maybe simply popping up a dialog box saying, "invalid SSL certificate" would be enough.

    If others would like help reproducing this, I'm happy to create an account on my webserver with an expired SSL certificate. You might be able to get it to work, however, simply by pointing to it over at https://epicenter.media.mit.edu/zotero. Of course, you won't be able to authenticate without an account.
  • Re: "status code 0", SSL certificate errors now display a more helpful message in 2.0b7.2, available now.

    The "status code 401" error, which this thread was originally about, is a separate issue. Let us know if you're still getting that.
  • I'm still getting the status code 401 error. Here is the number of the error report I just submitted: 966988824. I have 2.0b.7.2. downloaded.
Sign In or Register to comment.