Sync error

I'm getting a constant sync error. Could you please check report ID 1197529768.

Thank you!
  • [JavaScript Error: "Error: Error connecting to server. Check your Internet connection." {file: "chrome://zotero/content/xpcom/sync.js" line: 652}]"
    Are you still getting this? Very strange that you would be getting this in Firefox, if you can access this site and submit error reports. Can you access and ? You should see "Nothing to see here" for both.
  • hi Dan,

    Yes, it is strange, and yes, I can access both those addresses from the same Firefox, which is still giving me the same error (latest ID 873736941)

    Trying to think of possible causes, only thing I've done in these days was install a new style - could this be even remotely related?

    Any suggestions?


  • And you've tried restarting Firefox, I assume? If that doesn't help, try temporarily disabling all your other Firefox extensions, in case they're somehow causing this. If you're still having trouble after that, I can take a look at a Debug ID, which might have some additional info.
  • Dan,

    Yes, restarted Firefox, restarted Windows, disable everything but Zotero extension (even disabled Word and ZotFile plugins).

    Here's the debug ID: D1467931023

    I hope this helps.....

    Thanks again,

  • (3)(+0000045): HTTP POST 157849 bytes to (gzipped from 682554 bytes; 77% savings)

    (1)(+0000406): Error connecting to server. Check your Internet connection.
    Oh, hmm, so actually you're only getting an error on uploads — you're logging in and checking for updates just fine.

    I'm not seeing any sign of those uploads server-side. Is this a work environment? Is there a firewall or proxy server? If you're running any security software, you might also try temporarily disabling that.
  • No, this is actually a desktop at home, running Win 7, no proxies or anything, just going through a home router. Windows Security Essentials, no firewall other than Windows' one. I checked latest updates just in case, all I have are new Windows Security Essentials definitions in the last week.

    Nothing really changed, other than me installing a new style - I tried resetting the styles just now but didn't help.

    Please tell me you have other options for me, I'm willing to try anything as I really need this. My work laptop, going through the same router at home at least seems to sync just fine.

  • Yeah, this wouldn't have anything to do with styles. If you're getting that message, and particularly in absence of any server-side messages, there's a pretty good chance it's something on your computer or network.

    You can try manually transferring your library to the work laptop and syncing with that. Since this is only happening on upload, the work laptop might not show the same problem currently if there's nothing on it to upload, but if you transfer your data manually and then try to sync from there, you can see if the same thing happens.

    You can also add some items on the work laptop and try to upload them, both on that network and off.
  • Dan,

    I manually transferred the library to the laptop and it sync'ed just fine from my home network. So I guess the problem is with my desktop PC - very weird!

    Would you recommend me anything else about that one? i.e, would reinstalling Firefox/Zotero make any difference...?


  • Dan,

    Just for completion - I just uninstalled Firefox and reinstalled it, and it is synchronizing OK now.

    Thanks for the help, at least today I could work on my laptop whilst away after manually transferring the library to it.

  • Just to clarify, do you still have Firefox 46 after the upgrade? We'd want to make sure this works for you in that, not Firefox 45.
  • Yep, Firefox 46. I just generated a Debug D803904143 - not sure if you can tell from there it is the exact same setup from before.

    I have no explanations - but I'm happy it is working!

  • OK, glad to hear it's working now. If this comes back, let us know in and subscribe to that thread for updates. Thanks.
This discussion has been closed.