subsequent-author-substitute does not work


with each homework paper I develop the style I use further. In one of this modifications the style lost its ability to use
as defined and I cannot figure out what the relevant difference is (I compared the 2 style versions and none of the differences seem remotely relevant. But I don't want to go back to the old style because the differences are there for a purpose. Unfortunately, I only noticed after a while).

In both versions of the style there is the line

<bibliography et-al-min="4" et-al-use-first="1" hanging-indent="true" entry-spacing="0" subsequent-author-substitute="---">

With the old version of the style I get

Berget, Alphonse: A travers la Science. La Grande Revue 15.1.1904. S. 155–163.
---: Le Radium et les nouvelles radiations. Paris : Librairie universelle 1907.

With the current version of the style:

Berget, Alphonse: A travers la Science. La Grande Revue 15.1.1904. S. 155–163.
Berget, Alphonse: Le Radium et les nouvelles radiations. Paris : Librairie universelle 1907.

What could make the difference?
I realize you might say it could be anything and one would have to look at the style but there might be an obvious value.
  • Try in a new document and see if it works correctly in Chicago author-date. If it does, yes, we'd need to see your style. If it doesn't, the problem is likely the refferences (though author clearly looks identical).
  • Thank you for your suggestion. It took me a while to act on them because at the time I had to finish my paper ...

    I tried with a new document with Chicago author-date and it worked alright.

    I'd appreciate it if you checked my style. How can I provide it to you best?
  • edited August 21, 2016
    post the code to create a private gist (you won't need to register on github if you don't want to), link to it from here.
  • Hope I did it right:
  • It looks like the substitute function doesn't work if the author macro is used in both citation and bibliography. I think that's a bug, but it's easy enough for you to workaround:
    Simply copy the macro "contributor-long" and rename the copy to "contributor-long-note" (or whatever else you like) then use that macro in your citation and substitute will work.

    (You should, though, validate your style. You currently have a chooose pair in lines 410 and 412 that's not allowed)
  • This failure of subsequent-author-substitute should be fixed in the latest processor release, version 1.1.120.

    For testing, and for projects requiring an immediate fix, install one of the Propachi plugins to run the revised processor in current Zotero. The plugin should be removed at the next Zotero update.
  • Sorry for the late feedback, but nonetheless: Thank you for your help.
    I could get the desired result with the proposed workaround.
  • Is there a release of Zotero Standalone that has this implemented yet?
  • Actually just checked the version history. Looks like the answer is no. It would be great to get this soon!
  • Yeah, it seems to be at citeproc-js 1.1.60. As an interim fix, you should be able to install a Propachi plugin in the Standalone client.
  • OK I've got it installed now, but this issue still seems to occur. Do I need to do anything aside from installing the plug-in? Restart Word? Zotero Standalone?
  • Well I've done those things and I'm still having no luck in a brand new Word document with a fresh reference list.
  • Restarted computer still no luck.

    Maybe I installed it wrong? I just went to Tools>Add Ons>Install Add On From File and chose the Propachi Vanilla add in.

    My original post with CSL gist is here:
  • Do we know that propachi now works in Standalone?
    Also, do note my post above: there is an easy workaround for this:
  • I didn't quite follow that workaround...
  • sorry, I didn't read this closely enough. This isn't actually fixed.
    @fbennett -- subsequent author substitution fails for _single field_ authors (and only for those) when subsequent-author-substitute-rule is set to anything other than complete-all (i.e. anything but the default).
    Let me know if you need more explicit test cases.
  • edited November 11, 2016
    Do we know that propachi now works in Standalone?
    Yes, works in both versions of Zotero.
  • @adamsmith: Oh! Thought we'd squashed it, sorry. Will revisit the test.
  • Should be good in the release that just went out. Update available via either Propachi plugin.
  • This patch does indeed work now. Thanks very much for your help.
Sign In or Register to comment.