Upgrading of Zotero database failed

I finally decided to upgrade to Zotero 1.5, but there seems to have been a major issue during the migration. When firefox opened upon restart I got the Zotero upgrade database wizard and clicked Next. Then there was a pause for a while (maybe 30-40mins) while Zotero/Firefox chugged away. Then I saw this message upon completion:

Upgrading of Zotero database failed:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/schema.js :: _migrateUserDataSchema :: line 1872" data: no]

I hit the "send error report" button, but there was even an error in sending the error report and I ended up having to cancel out of the dialog.

Please, any suggestions on fixing this are much appreciated!

  • I adjusted my firefox about:config settings to allow Zotero error reports to be sent. I then restarted firefox and was prompted again to upgrade my Zotero database. I pressed Next and then waited another 30-45minutes, after which I received the exact same "database failed" error message as shown above. This time I was able to send an error report, though: Report # 564995555

    The Zotero panel will not open (message: "There was an error starting zotero.")
    I am running Windows XP with Firefox 3.0.6.

  • I successfully installed Z 1.5b on my Macbook, then came to work and installed it on my XP box. I got a similar error: TypeError: cases[l].indexOf is not a function ReportID: 1708250118 -- I get this every time I start Firefox now; will have to uninstall for now.

    I can't start Zotero, either; it has the !yellow triangle! and throws a JS error "There was an error starting Zotero."
  • Rick: You're getting some sort of error as Zotero tries to rename a file in the storage directory, but unfortunately the error message Firefox is producing gives us very little to go on. What I'd suggest is starting Firefox with debug output enabled, which should let us see what files it's choking in.

    Unfortunately, on Windows, the debug window results in a tremendous slowdown, so I'd recommend leaving the upgrade process running overnight or while you'll be away from the computer for a few hours.

    After you've set up the debug settings, you should be able to trigger the upgrade window again by closing Firefox and deleting the the files compreg.dat and xpti.dat in your Firefox profile directory. Then start up Firefox with the -console flag as described on the debug output page.

    If you haven't yet, be sure to back up your entire Zotero data directory before attempting the upgrade.
  • Amanda: We'll look into that error.
  • Oops, I "fixed" it before reading this. This won't help you debug, but what I did was this: I backed up my database to RIS format then deleted it from Zotero. After that the install worked. I didn't have anything crucial in Zotero that isn't also elsewhere, so even if I have trouble importing refs back in, I'll be copacetic. Looking forward to trying out the beta.
  • Sorry for the delayed response - I ended up following Dan's instructions to generate a debug report in firefox, but for some reason the installation worked that time (where it had failed several times before). I'm not sure what was breaking the install before. Thanks for the help!
  • edited April 17, 2009
    Alas, I'm running into a similar problem when I try to upgrade to 1.5--I suspect because (according to the database evaluation tool available via Preferences) my database is corrupt, even though Zotero 1.0 seems to be working just fine. I tried up upload my zotero.sqlite.bak.zip to the database repair tool, but got this error: "An internal server error occurred. Please try again later."

    Here's the debug output: zotero(3): Backing up database 'zotero'

    zotero(3): Saving zotero.sqlite.36.bak

    [extra output removed – D.S.]

    zotero(5): REINDEX

    zotero(5): Flagging nested transaction for rollback

    zotero(3): [Exception... "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: anonymous :: line 134" data: no] [QUERY: REINDEX] [ERROR: database disk image is malformed]

    zotero(5): Rolling back transaction

    zotero(3): Resetting Notifier event queue

    zotero(3): Shutting down Zotero

    zotero(1): Database 'zotero' is marked as corrupt--skipping backup

    zotero(1): Database 'zotero' is marked as corrupt--skipping backup

    [at which point firefox freezes]

    What now?

    Thanks for the help!
  • Lisa: Send us an e-mail at support@zot....org, and we can provide a download link for your repaired DB (which appears to have gone through successfully).
  • My upgrade to 1.5 failed as well. The error message told me to post this report ID to the forum: 849217491
  • Michael: If you don't mind, you could upload your Zotero database to the DB Repair Tool and send the Upload ID to support@zot....org, referencing this thread? You can ignore the download links the tool provides.
  • Michael: Thanks—this problem is now fixed on the trunk. The fix will be included in the next beta, which is in final testing now.
  • I will watch the site and download the next beta as soon as it is released.
Sign In or Register to comment.