How to correct numbering problem

This is a follow-up to a previous query that I put out on general discussion.

I have had a problem trying to correct an error in the bibliography. I use Zotero Standalone with Microsoft Word 2013 using Vancouver style.

I had been using the Zotero successfully but when I tried to enter a new reference, I received the message “You have modified this citation since Zotero generated it. Do you want to keep your modifications and prevent future modifications…Clicking yes will prevent Zotero from updating this citation or modify the item…Clicking No will erase your changes.” Zotero locks up on me at this point—it won’t respond to anything—clicking neither yes nor no works.

As a result of this problem, after reference #34 (Vancouver style), all of the references are “one off”. I have found the only way to correct the remaining references in this chapter is to delete each incorrect number and then use Zotero to insert the corrected reference—which then brings up the same error message. I have discovered that if I use the Windows Task manager to end Zotero task and then restart it, it corrects that number but then the next reference (#35) has to be changed using the same procedure. So I am going through one by one to correct the remaining 70 references in this chapter.

Is there any way to correct this other than the above procedure?

Has anyone else experienced this message or problem?

How can I avoid the problem in the future?

I have 9 more chapters to do in the book with 100-200 references per chapter so I want to avoid it occurring again.

Thanks for whatever help and suggestions you can provide.

Bruce Rocheleau
  • The first thing to check would be why you get that message at all. Do you ever modify your citations in Word rather than through edit citation in Zotero (e.g. removing/adding parentheses and the like).

    Do you routinely use track changes in your document? That shouldn't cause a problem but could potentially do so.

    My initial approach to fixing this issue would have been
    I doubt it was necessary to re-insert all citations.

    If you're not done going through them, it might be helpful to show Word field codes (alt+F9) and copy one for a citation that Zotero says has been modified and paste it here.
  • I may have used Word to try to edit references and will avoid doing that in the future.

    I tried to copy and paste the Zotero code for the next reference in the Word file but only the actual text is copied--not the Zotero code.

    Sorry for my ineptitude.

  • ah yes -- right-click --> Edit Field
    Select the Field code under "Advanced field properties" and copy.
    Click Cancel.
  • Adam,

    In using Zotero's Vancouver system, I insert the reference and then after the number of the reference is there, I often need to assign the specific page number(s) for that reference and I do use Word to edit the reference to insert the page numbers. Is this incorrect? Could it be causing my problems?


  • You mean you turn (2) into (2, p.53)? Yes, that could cause problems. In general, the way to add page numbers is the page field in the word add-on
    though that might not work for Vancouver. In that case, use the suffix field (i.e. ", p.53" as a suffix).
Sign In or Register to comment.