Word Plugin unresponsive no error message. Macros "Locked"?

Haven't seen this variation in the forum, or on troubleshooting page.

I am using Word for Windows 07, latest version of standalone. Zotero shows up in Word's menu, and opens with all the choices, but any choice I click yields no response, and no error message.

True on both document that already has citations and on fresh document.

I have tried
- removing and re-installing plugin.
- disabling my antivirus software.
- enabling all macros in word.
- entering into Developer/Macros and tried running the macros directly from the Macro dialogue
- From the macro dialogue, clicking "Step Into" button yields box titled "Product Locked", in which it says "Product is unviewable"
- With Zotero Standalone closed, I do get the "Word is not communicating with Zotero" message - so *something* is happening, it is just not resulting in the macros being run.
- Tried to repair word (in Programs and Features) no change.
- Ran an MS app called Easy Fix, which strips out some customization from registry - no avail.

Any help greatly appreciated!
  • SOLVED - but it leaves a mystery.
    I opened Word as administrator, and the plugin worked. but...

    For a while now, every time I open Zotero, it has opened a User Account Control Window that I think indicates that it is opening in Administrator mode. I saw then in (zotero.org/support/word_processor_plugin_troubleshooting) that both need to be run as the same user - admin or not admin, in this case.

    The mystery is that Zotero has been running as admin for a long time, and not Word, yet the problem only began recently. The other is why Zotero insists on opening in Admin mode
  • Same problem here. I wish I could stop running word as Admin. Any ideas?
  • Same problem. It has been a nuisance for me. I am having this problem in Excel as well. I am considering to permanently move out of Zotero to other alternatives.
  • This is not a general Zotero, but a system configuration issue. We have not been able to reproduce it or been reported steps to reproduce it, but it has to do with Word user data permission malconfiguration. This also shouldn't affect your ability to use Excel in any way. If you create a new user account on your computer you will see that Word is able to communicate with Zotero without running either as Administrator.
Sign In or Register to comment.