"Scannable Cite" not showing up in Zotero standalone

I've installed the RTF/ODF-Scan for Zotero but "Scannable Cite" is still not coming up as an option under "Default Output Format"—I've tried quitting everything, turning it on and then off again, etc. Anyone else have this issue? I'm on a Mac if that makes a difference.
  • And it's listed under tools-->Add-ons in Zotero Standalone?
    And you realize that it'd be listed all the way at the bottom, right? Zotero first list citation styles, then translators, so it wouldn't be under the first S, alphabetically so to speak.
  • Yes, it is listed under Tools -> Add-ons (it does have a "warning" that "Zotero LibreOffice Integration could not be verified for use," but according to other forum comments here that shouldn't matter—is that correct?). I've also just noticed that when I click "Tools" it only lists "RTF Scan..." rather than "RTF/ODT Scan..."

    And yes, I do know it's listed at the very bottom—I've scrolled through the whole list about a dozen times, hoping that I'm just overlooking the "Scannable Cite" listing...
  • When you right click on an item and select "Export item" -- is scannable cite an option then?

    Could you try just re-installing the addon, check if the translator exists, and if not provide an error report ID right afterwards, please?
    https://www.zotero.org/support/reporting_problems#provide_a_report_id
  • Hi Adam—I re-installed the add-on & restarted my computer as well—still not working. Here's my error ID: 1043734153. And thank you so much for your help!
  • And the answer to my first question is no?

    Which version of Standalone is this on? If you click on RTF Scan, do you see the ODF Scan options?


    @Dan -- do you see any translator install error in there?
  • The answer to your first question is no—when I click "Export item" there is no option for "Scannable Cite."

    This is Standalone version 4.0.29.2.

    When I click on RTF scan, there is no ODF scan option.
  • @Dan -- do you see any translator install error in there?
    No.
  • isabelhen -- we need to try this again. Please reinstall the add-on and provide the error report _immediately afterwards_ if you do it after a restart, there's not going to be anything helpful in there (and the add-on doesn't require a restart).

    Also, which operating system is this?
  • Hi, I'm a new user and I've also has some trouble finding scannable cite. I've tried both the standalone and the Mozilla versions. I’m on windows 10 but cannot see why that would affect the Mozilla settings? I’ve tried reinstalling it a few times and the RTF/ODF scan settings appear on both versions but no scannable cite. I’ve only just installed Mozilla so I’m assuming it’s the most current version. Apart from Mozilla wanting permission to install the add on I have received no error reports. I've also tried "right click export item" and scannable cite is not in the list. Thanks
  • You can just manually download the file from:
    https://raw.githubusercontent.com/Juris-M/zotero-odf-scan-plugin/master/resource/translators/Scannable Cite.js
    place it in your Zotero data folder
    https://www.zotero.org/support/zotero_data
    restart Zotero/Firefox and it'll appear.
  • Thanks, the manual download is working.

    Cheers
  • edited November 17, 2016
    Hi, I have the same problem - scannable cite is not showing up. But I am using the standalone version with Mac (Zotero 4.029.15). And I don't know how to download manually from the link you posted @adamsmith : https://raw.githubusercontent.com/Juris-M/zotero-odf-scan-plugin/master/resource/translators/Scannable Cite.js
    Could you tell me more precisely how to download manually?

    thanxx
  • Hi, HanSch

    I think you download it by right clicking and Save as...

    I've manually downloaded, but its still now working. Could it be that I am not using the default data folder? I've chosen the data folder I've specified, when I installed the .js file.
  • So, Hansch, I've found out how to do this.
    Right click on the link Adamsmith provides above, Save as to download the .js file. Then, go to the Zotero folder (you can do so by going the the Preferences, Advanced, Files and Folders, then click on Show Data Directory. Click on the Zotero folder. You should find an folder called Translator. Put the .js file in there. Quit Zotero, and reopen it. Scannable options should be there.

  • edited November 23, 2016
    Hello,

    I am on a very steep learning curve here - trying to make zotero work with Scrivener on a Mac and have wound up here having struggled to follow
    http://thedigitalresearcher.com/how-to-use-zotero-with-scrivener-part-2/
    and
    https://danielvreeman.com/using-scrivener-for-writing-scientific-papers

    I keep stumbling at the 'Install Add-On from File' step - I have downloaded RTF/ODF-Scan for Zotero but in Zotero standalone when I click Tools > Add Ons > Cogwheel > Install from file RTF/ODF-Scan it does not appear as an option. It is, however, listed as an add-on in my Firefox browster. I already have ZoteroLibreOffice Integration although there is a "warning" that "Zotero LibreOffice Integration could not be verified for use".

    Maybe I jumped the gun, because I manually downloaded scannable cite, as per the instructions on this thread, and it is now listed as an output option. However RTF/ODF-Scan is still not in my Add-Ons. Can anyone help?

    Many thanks in advance.
  • @sjpitman87 There are great instructions for installing RTF/ODF-Scan. It sounds like you're getting almost there but then you're unable to find the add-on installer you downloaded. By default, the add-on installation browser window only displays files ending in .xpi. Did you by any chance download the source code instead of the installer? Or rename the .xpi installer so it has a different file extension?

    To install the RTF/ODF-Scan add on, first download the RTF/ODF-Scan extension installer: currently zotero-odf-scan-v1.0.32-fx.xpi. Save it somewhere you can access it easily.

    Then, to install in Standalone, open Zotero Standalone and go to the Tools > Add-ons > Cogwheel menu and select "Install Add-on From File" (or similar). A browser window called "Select add-on to install" (or similar) will appear. In that window, navigate to the place on your computer where you have saved the RTF/ODF installer (e.g. Downloads). By default, that window will show only .xpi files.

    Once you have located the file you saved earlier, select it and click "Open". You will be offered the confirmation box. "Install" may be greyed out initially; wait a few moments and "Install Now" will become available. If it stays grey, click once to select the window. Click "Install Now". A moment later, RTF/ODF-Scan should appear in the extensions list.
  • @emmareisz Thank you! For some reason it was renaming the file extension automatically on download - all sorted now :)
  • Installation of the "Scannable Cite" translator should be fixed in the latest version (v1.0.33) of the RTF/ODF-Scan add-on, addressing the issue @lexymarshall experienced above.
  • edited December 1, 2016
    Hi. Today, I newly installed Z5.0 Standalone(r84+6900a5c) and tried to install RTF/ODF Scan for Zotero(1.0.33).
    However it didn't work properly with the error message:

    "The add-on "RFT/ODF scan for Zotero could not be installed. It may be incomptable with this version of Zotero Standalone."

    My system is Windows 7, and with Firefox+Zotero5.0(r83) it did install and work without error.

    ======================

    One more thing:

    When I updated FireFox(my current version: 50.0.2), [RTF/ODF Scan] menu was changed into [RTF Scan] with [RTF/ODF Scan for Zotero plugin] on add-on list of FFX. I re-install the plugin, then [RTF/ODF Scan] menu reappeared on Zotero menu. Why this?

    Thanks.
  • because the add-on isn't compatible with the beta version of Zotero.
  • OK. Then will upcoming formal version be compatible with the plugin? I understand.

    Thanks.
  • Yes, we'll get it to work with 5.0, but I can't promise it'll be in time for the final release.
  • Thanks again.
  • edited April 24, 2018
    I'm having the very same problem with Zotero 5.0 standalone, except placing .js in data folder manually does not help at all. Scannable cite does not appear in the export format list no matter what. Reinstalling Zotero/plugin also does nothing.

    RTF/ODF-Scan installation goes seemingly fine, but I'm giving report ID: 1782072645

    Previous times I installed Zotero and RTF/ODF-Scan it all went fine (on Win 7/10 64-bit; currently using Win 10 64-bit).

    UPD: On a seccond attempt it (pasting to Zotero/translators) worked. It seems I missed something, so excuse me for the false alarm.
Sign In or Register to comment.