Can't update Zotero Connector for Safari

I'm on 4.0.21 and set for automatic updates but for some time now have been unable to update. Safari shows an update available but when I click on "update" nothing happens. I've tried unclicking "Enable 'Zotero Connector' and then clicking "update" but still no luck. I will note that I have posted elsewhere on inability to authorize (Report ID:906109142), but I have no idea if this is related. Thanks in advance for any guidance. Zotero is a huge help in my work and I am grateful for it.

PS--Running latest El Capitan on 17" Macbook Pro Retina.
  • I had this problem as well, also latest version of El Capitan on 13" MacBook Pro Retina. I tried the same things, and then just gave up trying to make it work the way it should. As a workaround I uninstalled the extension and redownloaded and installed it from the zotero downloads page. A little annoying, but it worked.
  • Thanks for that. I deleted the old plug-in and downloaded the new one--but now it won't install. I click on "trust" and nothing happens. I've tried closing and reopening Safari, to no avail. I'd dearly like to have some functioning Safari plug-in! So any help would be greatly appreciated. Thanks.
  • Unbelievable. I was able at last to install the extension because of the following advice, which of course sounds insane:


    "Installing safariextz files works also if you use your keyboard to confirm the Trust extension source dialog. Mouse clicking on "Trust" button doesn't work.
    To install a safariextz file on OS X 10.11.1+, go to System Preferences > Keyboard > Shortcuts > Full Keyboard Access > select "All controls" option. Then double click on safariextz file and when the Trust prompt appears select the "Trust" button with your Tab key and confirm with the Space bar. This way extension installed just fine. Just don't use your mouse to click on the "Trust" button, it will not work."
Sign In or Register to comment.