Daily Telegraph bust

The translator for the Telegraph web site (telegraph.js) has stopped working. It hangs without populating the little window and doesn't save anything. I imagine the paper has done something to break it, but it would be nice to have it fixed.

Incidentally, is there any eta for a version of Scaffold that works with sync preview?
  • Thanks for reporting this. Ticket created.
  • seatrout,

    I am not finding any problems with our telegraph.co.uk translator. Could you send the link that is giving you trouble? thanks
  • Sorry to have been away fro so long. I can't get it to work on any pages at all of the Telegraph site at the moment.
  • edited January 21, 2010
    works fine for me, e.g. here:

    pls. follow the steps here and report back with detailed info (FF version, Zotero version, sample URL, error Report ID) if problems persist.

    After trying this succesfully on three different pages in three different sections I would suggest closing the ticket - this is not an issue with the translator.
  • OK. I think it has to be an issue with another extension. I have one profile with just zotero v1, scaffold, and dom inspector. That works, at least intermittently. My main profile, which runs a lot more extensions, fails repeatedly: it looks as if it fails in the detectWeb() function for some reason. I will try turning them off.

    If there is a bad reaction with adblock, I will weep salt tears.
  • edited January 22, 2010
    I run adblock plus without issues and I have never heard of any adblock related issues.
    edit: you have looked at the known incompatibilities?
  • I have looked at the known incompatibilities; they don't help. There is something very strange going on, though. Using Zotero 2.0b7.6 I cannot get any story on the telegraph site to be recognised properly. The Zotero icon in the awesome bar never changes to a little newspaper.

    I'll just work through all the extensions. But it doesn't seem affected by adblock or noscript. I wonder if it is urlbarext? will try that next.
  • OK. Solved this. My own fault entirely - I had a broken translator from when I was trying to learn how to write them that was picking up on the URL.

    Sorry. I will go back to trying to write one for the Guardian
  • Someone already wrote a Guardian translator, but it was never added.


    Feel free to test it and respond to that dev list thread with feedback.
  • Ah. Great. Since I actually work for the Guardian, I want one.

    Also, has anyone written an FT translator?
  • closed the telegraph ticket.
  • Also, has anyone written an FT translator?
    I don't believe so.
  • @ Dan Stillman

    I'll just comment here first as I'm not sure if I can contribute so much even if I join the zotero-dev group. I just wanted to mention that The Guardian translator didn't quite work for me. I didn't see any icon popping up on my address bar on any of the articles. Maybe it's because it was created more than a year ago?
  • edited January 28, 2011
    I just tried again after installing 2.1b5 and the embedded RDF is now being recognized. I'm not sure if it's due to this translator or you guys fixed the RDF (I get the feeling that it is the latter). Anyway, The Guardian now has RDF at least. Thank you!
Sign In or Register to comment.