Firefox Sync Not Working: Zotero.Sync.Server.Data.processUpdatedXML()

Error 398094126

I can't get the Zotero Firefox plugin to sync. At first, I kept receiving an error about local vs remote tags, and I kept getting prompted to resolve conflicts for the same files. I deleted them, and now I'm getting the following error:

"Related item doesn't exist in Zotero.Sync.Server.Data.processUpdatedXML() (null/PUBC7W9S)"

Updates aren't showing up remotely. Database integrity checks indicate that the database is in good shape.
  • How about now?
  • edited January 25, 2016
    I still get the following error:

    Related item doesn't exist in Zotero.Sync.Server.Data.processUpdatedXML() (null/PUBC7W9S)

    The standalone Zotero client seems to be synchronizing properly. Do you have any ideas for why the Firefox plug-in is not synchronizing?

    Should I uninstall the Firefox plug-in and then reinstall it?

    I recognize that doing so will likely cause me to lose changes, but I really like having the Firefox plug-in.
  • In case it helps, I ran the sync process again and reported the error, which is Error Number 869236338.
  • Standalone and Zotero for Firefox on the same computer should set to use the same data directory, and if they are then syncing should behave identically. The easy test for this is trying to open both at once. You shouldn't be able to — clicking the Z icon in the browser should just bring Standalone to the front if it's open. If that's not the case, change Zotero for Firefox to point to your Standalone data directory, and move your old Zotero for Firefox data directory to a backup location until you're sure you don't need it anymore.
  • Error ID: 2068628376

    OK, I really need help now. I've done all of the following, and nothing has helped.

    1. uninstalled Zotero plug-in

    2. Reset Firefox

    3. Reinstalled Zotero Plugin

    My library is empty, and I still get the same error mentioned above:

    Related item doesn't exist in Zotero.Sync.Server.Data.processUpdatedXML() (null/PUBC7W9S)

    Do you have any other ideas I could try?

    Please note that I'm using GoDaddy WebDav for my storage location, and the Zotero native client doesn't seem to have any problem with it.
  • Did you see my message above?
  • I did see your message previously, but I didn't fully understand it.

    Long story short: I copied the directory location specified in the standalone Zotero app (which appeared to be a Firefox profile location) and told the Firefox Zotero plugin to use the same path. After doing so, it seems to be working now.

    I lost a bunch of changes that were made with the Firefox plug-in, but so long as its working now, I don't mind too much. I really like Zotero, and I've been using it for many years with no problems, so I can tolerate a hiccup like this periodically. Thanks for making this great tool available and for following up here so promptly!
  • If you want, you can temporarily switch back to the previous location, sort by Date Added or Date Modified in the middle pane, export recent changes to Zotero RDF, switch the directory back, and import the RDF file.

    Not sure how you ended up getting this error, but the next major version of Zotero will include a completely revamped syncing system.
  • (Also remember to archive and eventually delete the old data directory so they don't get mixed up in the future.)
  • I'll give your suggestions a try. Thanks again for the really helpful tips!
Sign In or Register to comment.