Report ID 1270469919 - Syncing on new computer


After setting up Zotero (using FF 43.0.4, Zotero plugin) on a new computer, I'm getting "The attached file could not be found" for most attachments in my personal library. The exceptions seem to all be in some folders that I had imported into my personal library. The attachments in my group libraries also seem to work.

So far all the attachments I've checked have still been available in my online storage. So I'm wondering if I should just try starting over on the new computer, or something else -
  • Thanks, I will check this out when I have access to "Computer A" tomorrow -
  • Hi,

    So I double-checked computer A - syncing still works fine, the attachments are there, and I made a new backup of the local Zotero library on that machine. FIle attachments are also still in my library on

    The new computer/"computer B" is still missing many attachments, and does not produce an error when syncing. For some reason on computer B now, I am also not seeing any of my subcollection folders or groups in the browser pane. (Looks like the citations from my subcollections are there under "My Library"; it's just the subcollection folders that aren't showing up).

    Should I do the "Reset File Sync History" thing? Or maybe "Restore from Zotero server"?
  • definitely don't do "Restore from Zotero server".

    My guess for why you're not seeing groups and collections might be because they're collapsed -- have you tried clicking on the little triangles next to "My Library" and "Group Libraries"

    If sync goes through on Computer B (run a manual sync to be sure -- click the green round arrow at the top right, wait until it stops to spin, then make sure it says something recent as the time of the last sync when you hover over it) and you still don't have attachments, go ahead and try Reset File Sync History.
  • ra
    edited January 25, 2016
    Thanks -

    I tried to expand "My library" multiple times yesterday, no dice. The "Group libraries" section was entirely missing, nothing to expand. Ran sync manually multiple times. No sync errors, the last sync time was appropriately updated, but the same attachments were still missing.

    It just seems like Computer B is extra messed up... so then I'm leery about transferring Computer B's messed-up-ness to the version which at least doesn't *look* messed up.

    But if all else fails, it should still be possible to restore the backup of Computer A's library to the server, yeah?
  • If you're not seeing groups, see Changes Not Syncing.
  • sorry to ask, but could you double-check that you have the same username on computer B in the sync pane of the preferences as on computer A?

    I'm not worried about anything getting lost on the server because of sync, so no worries there.
  • Thank you both. Here's where I'm at...

    - Username on computer B matches computer A

    - Did the Reset File Sync History and synced

    - Got a few warnings from Avast about files in

    - Excluded* from Avast scanning & resynced, didn't get any error notifications

    - Subcollection folders & groups are back

    - Attachments are still missing

    - Did the reset + resync a couple more times for the heck of it, still no error messages but attachments are also still missing

    - Submitted a new error report: 1125949240
  • OK, so we can ignore everything before you disabled Avast and got data sync working again. Now that that's OK, try the Files Not Syncing steps again, and provide the info requested there.
  • - Computer A has file syncing enabled and syncs properly. There are no sync errors on Computer A.
    - Files are uploaded to correctly from Computer A.
    - I'm not using WebDAV, I'm using Zotero storage
    - The attachments that are missing from Computer B all seem to be present on
    - The file sync settings on Computer B match the file sync settings on Computer A.
    - I don't get a sync error on Computer B.
    - Ran the Reset File Sync History and re-synced on Computer B multiple times.
    - Submitted this error report: 1125949240
  • If you've performed all these steps, see the file on the server, and still can't access the file on Computer B, then go to the Sync→Reset pane of the Zotero preferences on Computer B, choose Reset File Sync History, generate a Debug ID for the next sync attempt and an attempt to open the file, and post the Debug ID to the forums.
    (You provided a Report ID.)
  • And make sure you disable your other extensions before trying. You should also temporarily disable Avast on a system level if you haven't, not just within Firefox.
  • ra
    edited January 30, 2016
    Thanks, here's a debug ID D1329273991

    But this time I got the error below. That's after doing the Reset File Sync History thing again, with Avast and FF add-ons disabled -

    The file 'C:\Users\surrogatekey\AppData\Roaming\Mozilla\Firefox\Profiles\6e8tx9z1.default\zotero\storage\BX3UTKIT\Repace - 2009 - Secondhand Smoke in Pennsylvania Casinos A Study .pdf' cannot be created.

    Check that the file is not currently in use, that its permissions allow write access, and that it has a valid filename.
  • I'm afraid that's still an issue outside of Zotero — likely Avast or some other security software running on the system. It just means, as it says, that Zotero via Firefox isn't able to write to the disk, and there's nothing Zotero can do itself to fix that.
  • Ugh, I just wrote a novel length comment and then lost it. Probably better that way.

    Short version: Tried various machinations w/ original profile location, but couldn't get it working. Uninstalled add-on, then installed standalone version & synced, then re-installed add-on and told it to use the standalone profile -> so far, so good.

    Also: I can't live without you, Zotero :)
  • The saga continues...

    So whereas before attached files couldn't be located on computer B, now when I add an item on computer B, the attached file can't be found on computer A. The attached file does show up in my Zotero storage/online library.

    When I add an item on computer A, the attached file shows up everywhere - computer A, computer B, and my online library.

    No errors when I sync -
  • edited February 29, 2016
    Nothing we can comment on here in the abstract.

    We'd need a Debug ID for the first sync on Computer A after you add an item on the other computer and it appears online, followed by an unsuccessful attempt to open the file.

    Also, make sure the file is actually accessible online, not just that the attachment appears.
Sign In or Register to comment.