Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorcharlener
    • CommentTimeJan 30th 2009 edited
     
    (Unless I'm missing something or this is intended functionality)

    In openoffice with the zotero extension, if I select a chunk of text with references, then cut and paste it elsewhere, all the field markings and reference numbers are correct. However, if I copy instead of paste, the fields are off (only a little 1-character-width bit) and the numbers are all plaintext outside of the field.

    Should copy and paste work like cut and paste, or are there reasons that copy doesn't work?
    • CommentAuthoradamsmith
    • CommentTimeJan 30th 2009
     
    Yes, that's true if you paste to the same document -
    to a another document Copy&paste works fine.
    My guess would be that this is intended - each citation has a unique identifier and Zotero would get confused if that identifier wouldn't be unique anymore...
    • CommentAuthorjoehill
    • CommentTimeJun 5th 2009
     
    I just tried copying and pasting from an old draft into a new draft in openoffice.org, and the citations work in the original but act like plain text in the new one. So at least for me pasting into another document doesn't work. It's really inconvenient when working with multiple drafts to have to redo every single reference every time I copy and paste a section.

    This seems to me to be a bug, whether it applies to pasting within a single document or between documents--the process of having to select references all over again is extremely time consuming. Maybe there's a way to assign a new identifier to the pasted reference?
    • CommentAuthornoksagt
    • CommentTimeJun 5th 2009
     
    If you start the new draft & first set the bibliographic options to be the same as the old draft, pasted citations should work.
    • CommentAuthorjoehill
    • CommentTimeJun 5th 2009
     
    Sorry to say that's not the case here. I always use the same options in every document. When I pasted multiple paragraphs at a time, the references came out as plain text, but when I just pasted the reference, not whole paragraphs, it appears to copy as a reference but it does the same thing that always happens when a reference gets broken--when I try to highlight it it automatically gets selected but then I can't edit it.
    • CommentAuthoradamsmith
    • CommentTimeJun 6th 2009
     
    hmm - do you work with bookmarks or fields?
    I've used this many times with fields in Ooo and have never had a problem so I find this a bit puzzling - just tried it out again using 2.05 and Ooo 3.1 - works smoothly.
    It does require what noksagt says, though - you need to insert one initial citation in the new document to set the preferences, only then does pasting work.
    Not sure how to troubleshoot this - maybe you can describe your exact workflow step by step?
    • CommentAuthornoksagt
    • CommentTimeJun 6th 2009
     
    you need to insert one initial citation in the new document to set the preferences, only then does pasting work
    I believe that you can just set the document preferences for citations, without needing to insert an initial (dummy) citation.
    • CommentAuthoradamsmith
    • CommentTimeJun 6th 2009
     
    yep, that works, too.
    Just tested - this does indeed _not_ work with bookmarks (neither option), so I suspect that's what's going on for joehill.
    • CommentAuthorjoehill
    • CommentTimeOct 8th 2009
     
    Sorry, I was away for a while and didn't follow up on this.

    I was using bookmarks when I had this problem but more recently I've been using reference marks (this is the same as fields, right?) and have not had this problem. I will update if I find otherwise.
    • CommentAuthoradamsmith
    • CommentTimeOct 8th 2009
     
    yes, reference marks and fields are similar features of word and Ooo respectively. I always get confused which is which.
    • CommentAuthorploring
    • CommentTimeNov 5th 2009
     
    I am battling with this problem while trying to put my dissertation together. Obviously re-inputting hundreds of citations is the last thing I want to do here...

    To get an update, is it established that pasting into another document does NOT work with bookmarks? If so, is this a bug that is being worked on? Using bookmarks is essential because I need to write these files in .doc format. Is there a solution in sight or am I going to need to use something other than Zotero?

    Thanks
    • CommentAuthoradamsmith
    • CommentTimeNov 5th 2009
     
    I'm not sure "bug" is the right word here, but afaik this doesn't work and I haven't seen any movement - I'd guess it's a structural limitation of bookmarks.
    To be clear: the problem just exists if you really need to be able to switch your document back and forth between word and open office. Both Word Fields and Ooo Reference Marks will work fine.
    Why do you need to write in .doc, rather than just export a .doc version from time to time?
  1.  
    If you're having trouble, you can always edit in Reference Marks mode and .odt and convert to bookmarks/.doc when saving. There may be a few different issues here, but handling of bookmarks during copy and paste doesn't really have anything to do with Zotero—they're just bookmarks, and it's up to OO what it does with them (e.g., if it needs to modify the id of the copied bookmark to ensure uniqueness). The use of bookmarks is essentially a hack for cross-word-processor compatibility, and there are inherent limitations. Perhaps Zotero could tie into the copy/paste routines and intercept the process and do something more intelligent, but I have no idea if that's actually possible.

    Edit: What adamsmith said.
    • CommentAuthorploring
    • CommentTimeNov 5th 2009
     
    I see... thanks for the elaboration. The trouble I was trying to avoid by writing only in .doc is for when committee members send edits made with track changes... so I wouldn't have to work with two open documents, my .odt and their .doc, having to add changes by hand to my odt... Its workable though... thanks!
    • CommentAuthoradamsmith
    • CommentTimeNov 5th 2009
     
    yeah - I agree that's an issue, but I don't think there is much you can do about it. Maybe Refworks, but I have my doubts.
    • CommentAuthorboycer
    • CommentTimeFeb 2nd 2010
     
    Going back to the original question placed by Charlener ...

    This sort of reference copying occurs fairly frequently when writing grants or dissertations because there tends to be some core references that support the main arguments of the author. Coming from LaTeX/BibTex, copying references was very straightforward. If identifiers are the issue, would it be possible for the Copy and Paste function to automatically assign a new identifier to a Zotero citation object so that one could copy citations within the same document? I imagine that there any hooks within OpenOffice that allow methods to be called after copy and paste; if so, these might be useful for such a task.
    • CommentAuthorbp
    • CommentTimeFeb 22nd 2010
     
    Indeed, inability to copy citations within document causes a lot of pain, it would be nice to have such feature.
  2.  
    I agree with bp, not being able to copy and paste citations within a document is a big inconvenience. A fix for this should have a high priority.
    • CommentAuthorRicazz
    • CommentTimeMay 19th 2011
     
    Hi!
    I just tried to unite a couple of chapters of my dissertation, copying and pasting the second chapter from its file to the file with the first chapter... In the pasted section (second chapter) all the notes appeared as "plain text", ie they lose the format as zotero notes, making me unable to refresh them and change the style.
    The same seems to happen if I copy and paste a section with notes within the same document.
    Is there any solution to this problem?

    I use OpenOffice 3.3.0, zotero 2.1.6, on a windows vista laptop.
    • CommentAuthoradamsmith
    • CommentTimeMay 19th 2011
     
    Ricazz - copy and paste between documents should really work (c&p within one document never has) - are you using bookmarks of reference marks (check document settings in the Zotero Ooo plugin)
    • CommentAuthorsteve_c
    • CommentTimeJun 24th 2011
     
    I've found - using Zotero 2.1.8 and LibreOffice 3.3.2 (so I presume this will be the same for OpenOffice) with ReferenceMarks that field codes are lost when I cut and paste between documents unless I click Set Document Preferences for Zotero in the new document before I paste for the first time.

    So long as the second document has its Zotero preferences set everything works fine.
    • CommentAuthorRicazz
    • CommentTimeJul 3rd 2011
     
    Thanks, Steve! that seems to work ok, now... I'll do some further tests later on...
    AdamSmith: actually it seems to work even the copy&paste within the same document, now

    (I must confess I've been quite busy in the last two months, so I do not know if there has been some great change in the softwares)
    • CommentAuthoriphigenia
    • CommentTimeSep 13th 2011
     
    Hi, I have the same problem that charlener originally described: copy+paste just pastes plain text, which is extremely annoying when having to refer to the same text again and again. Is there any way around it? (pasting into another document does work, but pasting back into the original document is plain text only again). If not, are there plans to fix this?

    (I am pretty sure this worked in a previous version of Zotero?!)
    • CommentAuthoradamsmith
    • CommentTimeSep 13th 2011
     
    I doubt this has worked before - note the original post is from early 2009... my understanding of the way the fields work is that each of them is unique, because it includes information on its position in the document (so that things like subsequent citations, ibid, op cit etc. can work) - hence no copy and paste.
    The new word processor plugin for 3.0.2b looks like it would make citing much faster.
    • CommentAuthorSimon
    • CommentTimeSep 13th 2011 edited
     
    This has never worked in OpenOffice.org. It doesn't matter to us whether the fields are unique or not, but OpenOffice.org enforces that they are and strips the code. We can't control how OpenOffice.org implements copy and paste, so there's no workaround. Copy and paste works with bookmarks and Word fields, but not OOo ReferenceMarks.
    • CommentAuthoriphigenia
    • CommentTimeSep 13th 2011
     
    Thank you for your quick replies! And sorry for my bad memory, maybe I was using Word unconsciously. :D
    Is there a way to work in bookmark mode and later switch back to ReferenceMarks (it seems to mess up the references at the moment)?
    Also, thanks for the hint towards 3.0 - the Quick Referencer indeed makes things easier, even if copy+paste doesn't work.
    • CommentAuthorjillyb23
    • CommentTimeDec 17th 2011 edited
     
    I'm using MS Word 2011 for Mac and have just discovered the same problem. When I copy and paste the little bits I've been working on into one file, all of the links disappear and I'm left with nothing for a bibliography....

    EDIT: OK ... GOT IT!

    For anyone as dense as me, let me explain what needs done.
    Open your document that has the functional links.
    Don't copy yet.
    Open the new document into which you want to paste your text.
    Don't copy yet.
    With your empty document on top, look in the little Zotero toolbar where you add and edit your citations and find the icon that has a little grey wheel. If you run your mouse over it, it says "Zotero Set Doc Prefs'. Click it and choose your citation style. There is no need to change from 'Fields' to 'Bookmarks' in either document.
    Go to your old document, copy, and paste it into the new one.
    The links work! :D
    I <3 Zotero
    • CommentAuthoremreg00
    • CommentTimeMar 28th 2012
     
    I have a related problem: I have written the text using OpenOffice and Zotero (references in Bookmark format, I save the document in doc format and another person modifies the text on his MS Office) and now I want to copy the contents to another OpenOffice file keeping the citations. In addition to the suggestion above (cutting instead of copying), I tried to convert the doc document to odt and then cut & paste but I could not make the cut citations to be recognized in the new OpenOffice file. I also tried to the same with MS Office (http://forums.zotero.org/discussion/12047/converting-openoffice-odt-to-word-doc/) but it did not work either (MS Office could not see the references though OpenOffice in Windows was fine with them).
    Has anyone managed to achieve copying (cutting) of citations from a DOC file written in OpenOffice (and then modified in MS Office) to another OpenOffice file?
    I guess this is quite a particular case but I hope to have some suggestions before I start inserting again 60+ citations in the new document.
    • CommentAuthoradamsmith
    • CommentTimeMar 28th 2012
     
    did you make sure to set the citation style in the new document before pasting the citation in - either using "Set Document Preferences" or by inserting one citation?
    • CommentAuthoremreg00
    • CommentTimeMar 28th 2012
     
    Hi adamsmith, yes I had done it. The funny thing is if I try to edit citation it says sth like "place the cursor to a zotero citation" but if I try to insert citation it pops up "are u sure to modify citation".
    • CommentAuthorRivergirl2
    • CommentTimeMar 22nd 2014 edited
     
    When I want to rearrange my Libre office document but keep the links to my cites working (so I can still edit them) I do the following:

    1) Look at the Zotero toolbar at the top of your document where you add and edit your citations and find the icon with the little grey wheel. If you run your mouse over it, it says "Zotero Set Doc Prefs".

    2) Click it and choose your citation style again. You don't need to do anything else.

    3) After that, copy and delete the section that you want to repaste and repaste the section somewhere else.The cites should be "live" but the numbers will be in the wrong order

    4) Go back to the Zotero tool bar and find the icon with the little arrows going in a circle. If you run your mouse over it, it says "Refresh". Hit it. Your cites will now be numbered correctly.

    repeat as necessary. Good luck to everyone working on a dissertation!

Zotero Forums are powered by Vanilla 1.1.5a