I cannot view pdf after installing zotfile

I installed zotero and zotfile extensions in firefox, and "custom location" to my dropbox drive and set to rename my pdf file in the settings of zotfile.

The problem is that the pdf file cannot open after I double click a item, but a diaglog "save to" just bring up.

But I can open the pdf file with right click and "open in external viewer", and I can open the pdf file loation with "show file".

I would like to double click to open the pdf file, because it's simple and quick.

Can anyone help me? Thanks for your attention.
  • edited November 15, 2015
    I have got the answer.

    Check the box "Do this automatically for files like this from now on."

    But the icon of the attached file changed, not the previous pdf icon. Maybe it's a bug.
  • no, the changed icon is not a bug: ZotFile, set to custom location, links files to a location outside of Zotero, so you get the "Linked file" icon. The PDF (and similar) icons are for files stored as attachments in Zotero.
  • Hi all, I have the same issue raised by pengyun04 but still not clear about the solution. I've installed Zotero (Firefox version) and Zotfile as well months ago with no problem, and seems to be since last week that PDFs (alone or by clicking on parent items) cannot open. A zotfile message is also displayed every time at lower right corner. Find below log's entries.

    Thanks in advance for your kind attention:, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Firefox, appVersion => 42.0


    (3)(+0000000): Opening D:\My Library\storage\VW2JZ6Z6\_export_sites_paymentssource_05_data_media_pdfs_TCPA_Compliance_FAQ.pdf

    (3)(+0000001): Detected MIME type application/pdf

    (4)(+0012763): Registering observer for [collection,search,share,group,trash,bucket] in notifier with hash 3T'

    (3)(+0000004): TypeError: aId is undefined
    ===== Stack Trace =====

    (4)(+0000002): Registering observer for [item-tag,setting] in notifier with hash wy'

    (4)(+0000001): Registering observer for [item] in notifier with hash q2'

    <<< log's entries end
  • So you can also still open via right-click --> open in external viewer, correct?
    Then what you're seeing is a file handling problem in Firefox. You can either try to figure this out in the application settings (Preferences --> Applications) in Firefox and try adjusting the settings for PDFs, or you can see here: https://www.zotero.org/support/kb/file_handling_issues
  • Hi Adam, thank you very much for your prompt reply. You're absolutely right. Issue solved just by adjusting Firefox settings for PDF. Please apologies for disturbing you with these no-Zotero topics, and thanks again!!!!
  • I feel sorry for not reply to you, I was busy these days and writing a paper for Ph.D application.

    Thanks very much for adamsmith's help! Wish you good luck!
Sign In or Register to comment.