OOo plugin: BASIC runtime error

I know this sort of bug (?) has come up before, but I still don't know how to work around it:
A small file (.odt) I've been working on for some time (including references) no longer allows working with the zotero plugin.

Manually deleting all the references does not work, but copying the full content (incl. zotero references) into a new odt file seems to solve the problem. That would seem to indicate some zotero metadata in the odt file is causing the problem, right? (sorry about the non-technical hypothesis, I'm no hacker).

The error message is as follows:

BASIC runtime error
An exception occured
Message: .

In the OOo Basic window, the following line is highlighted within "Function fnRangeComp(m1, m2) as boolean":

"fnRangeComp = thisComponent.Text.compareRegionStarts(oR1, oR2) > 0"

Any ideas?

[zotero 1.0.9, OOo 2.4, OOo plugin 1.0.b4, Debian testing]
  • Oooops, sorry

    I posted this in the wrong section. Is there any way to move the post to "troubleshooting"?

  • Does it happen if you remove all content and have an ostensibly empty document, or only if you remove visible references? E-mail an .odt with as much as possible removed that still produces this error to, and we'll take a look.
  • Thanks, I've just done that.

    Even when the whole text is deleted, the error persists. The OOo Navigator still shows all the Zotero References (despite having deleted them).

    Thanks again,
  • edited January 15, 2009
    EDIT: Deleted irrelevant comment on non-functioning drag and drop.
  • Hi again
    I was able to reproduce this issue:

    Using the same versions stated above, I modified an author name in a Zotero entry to avoid the initial showing up in the citation (, and hitting the refresh icon in the OOo extension the same error came up. I can no longer use that document with Zotero.

    The document navigator shows 3 "ghost" Zotero references which are nowhere in the text and I cannot delete. All three references are for the same item (ItemID 12035).
    How can I find out what "ItemID 12035" is in my database? Might it be one of the references I modified?

    So somehow, the error line:
    "fnRangeComp = thisComponent.Text.compareRegionStarts(oR1, oR2) > 0"

    is related to a change in the zotero database that somehow "breaks" the communication with OOo?

    [I've been unable to find how to delete References in OOo other than in the text... ]

  • Same problem here (and no backup, silly me). Could it be the cross-references I added to my document?
  • SOLVED (somewhat) by enabling show changes in OOo
Sign In or Register to comment.