Zotero Standalone experienced an error updating my Word document

When I try insert a citation with Zotero Standalone 4.0.28 into any Word 2010 document, I get the following error:

C:\Program Files (x86)\Zotero Standalone\zotero.exe
Zotero experienced an error updating your document.
(intermediate value)[command] is not a function

It worked in the past - with the nice feature that the Word plugin recognized whether to add or edit a citation. Now it shows Add/Edit Citation all the time. In the Zotero Standalone preferences it says that the Microsoft Word add-in is not installed, while in Zotero Firefox it shows that the add-in is installed. I tried re-installing in Zotero Firefox but it still is not recognized in the standalone version.

What do you advice?
  • edited September 26, 2015
    For the document, try this:
    edit: unless you're saying that's the case for an empty document, too?
    In that case, make sure that both of your Word add-on versions, listed under Tools-->add-ons are the same

    The add/edit button does no longer change depending on context--that caused to many problems--but its behavior is still context dependent.

    Don't worry about the installed message in Standalone.
  • Yes, the error also occurs with an empty Word document.

    ZFF has version 3.5.2 installed (last updated 2015-09-26).

    ZSA has version 3.1.20.SA.4.0.28 installed (last updated 2015-09-18). Checking for updates results in "No updates found".

    What can I do now?
  • interesting -- does the error occur both with Standalone closed and with Standalone open?
  • Only with Standalone open. If I use Firefox, it works.
  • OK, do that for the time being. New Standalone version should be out shortly & will fix this.
  • Okay, will do. Thanks for the info.

    Now that I started using Standalone, I don't want to miss it anymore.
  • Zotero Standalone is now available (at least for Mac and Windows) and should fix this.
  • Thank you adamsmith,
    it was useful for me too (I have the same problem).
    Zotero citation can run with Standalone close.
  • almuberto -- this should be fixed with the new Standalone version as per Simon above. If that's not the case, please post back here.
  • @almuberto

    The new version works for me.
  • Greetings. I was running Zotero Standalone 4.0.28 (Windows) and ran into the same problem, in existing and new documents. I downloaded the new version and am grateful the problem is fixed for me. Thanks!
  • My Standalone is giving me fits as well. Having to close and re-open both Zotero Standalone 4.0.28 and Word (2011 for Mac). ... JUST as I was typing this, I was also re-opening ZS. Got the new version ... let's see how it goes.
  • Update from a librarian in the field:

    I encountered the same issue with a student's computer (Windows 8.1, Word 2013). The problem was that there were two different Word add-ins installed simultaneously, one for an outdated version of Standalone, and the other for an updated version of Zotero for FF. Updating Standalone and reinstalling the Word add-in seems to have fixed the problem. In fact, the Standalone add-in was so outdated that there were simultaneous Zotero menus in Word: one updated version labeled "Zotero" that was broken when Standalone was open before its update, and one under the "Add-ins" menu that seemed to work just fine before updating Standalone. After updating Standalone, the Add-ins menu is gone, and everything seems to be working fine.
  • I just downloaded Standalone using Chrome. I can save information to Zotero as shown in the browser. However, I couldn't find the Word add-in in my Word file and I can't find Zotero in my PC after I downloaded or even typed it in search programs and files. What should I do about it? Please advise. Thanks!

  • 345268635
  • @EM2kika If that is an Error Report ID, please start a new thread and explain in detail your problem, along with the ID.
  • Using word plugin and firefox, I am now getting this same error when I try to create a bibliography:

    C:\Program Files (x86)\Zotero Standalone\zotero.exe
    Zotero experienced an error updating your document.
    (intermediate value)[command] is not a function

    Any help? Using Zotero 4.0.29...
  • got it fixed, with Zotero 5.0. Apparently it was a common issue with 4.0

    Going to have to get used to using Z standalone now.
Sign In or Register to comment.