Sync error # 1627808981

Using zotero on two machines. Mac os x at home and windows xp at work.

Today when I tried to interact with my zotero library at work I encountered the following error ID 1627808981 - I think it was related to library conflicts.
This occured on sync 1.5-sync3.5. When restarting firefox after the error, zotero was updated to 1.5-sync3.6.

Back home in evening zotero was updated to 1.5-sync3.6 on mac when starting firefox. Then sync'd - a few files were uploaded during this sync but not downloaded - It may be worth noting that I had actually expected these files to have already been uploaded when I added them over the weekend. In fact I had been expecting sync to be working 'on demand' ie as soon as an item is added to my library I expected sync would be run. Therefore I have not been manually pressing sync eg when closing firefox at the end of the day. Should I be?

Anyway, then closed firefox. VPN'd into work and tried to sync work zotero. Not sure exactly what happened here - seemed to go too quickly to involve any downloads. But was informed there was a conflict. Pressed finish instead of the option to keep local version.

However, the error remains - I can see the library in firefox on the work machine but whenver I try to interect with it (ie select an item) I get told there is an error.

Please note, I have consciously tried to avoid situations where zotero library is simultaneously open on two machines (when using VPN to work machine), but as mentioned previously I have not been manually syncing as a matter of routine when closing down zotero.

I would appreciate advice on steps to take to recover access to library on work machine.
  • Have you recently made any changes on your work computer that might affect the system time settings or file timestamps? You're hitting a bug that's been reported before on Windows in which the timestamps of files that Zotero sets and then retrieves are off by exactly one hour (when they should of course be identical if the file hasn't been changed). Unfortunately, we haven't been able to reproduce this. Have you been successfully syncing files up to now?

    What's the error you're getting when you select items on the work computer? All the errors in the error report you sent are related to syncing and shouldn't affect normal usage of Zotero. Does the problem persist after restarting Firefox?

    (The data and files likely didn't autosync over the weekend, by the way, because we set expiry dates on the autosync of Sync Preview builds, and 3.5 expired on January 1st.)
  • I have not knowingly made any changes that might affect time settings or time stamps.

    I only activated the sync feature of Zotero a few days before the error. In that period I probably only switched between machines 2-3 times, but the sync did seem to work ok to start off with.

    Now when I try to select an item, the list of items in the central panel completely disappear from view and the following message appears in their place:

    "An error has occurred. Please restart firefox. You can report this error by selecting "Report errors..." from the Actions (gear) menu."

    The report consists of the following (but I guess you already know this part):

    [JavaScript Error: "Conflict! Last known mod time does not match remote time! (1207830456 != 1207826856)" {file: "chrome://zotero/content/xpcom/storage.js" line: 2307}]

    [JavaScript Error: "[Exception... "'Invalid integer value 'NaN'' when calling method: [nsIWebProgressListener::onStateChange]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]

    [JavaScript Error: "Conflict! Last known mod time does not match remote time! (1178731280 != 1178727680)" {file: "chrome://zotero/content/xpcom/storage.js" line: 2307}]

    [JavaScript Error: "Conflict! Last known mod time does not match remote time! (1178726794 != 1178723194)" {file: "chrome://zotero/content/xpcom/storage.js" line: 2307}]

    [JavaScript Error: "Conflict! Last known mod time does not match remote time! (1178726720 != 1178723120)" {file: "chrome://zotero/content/xpcom/storage.js" line: 2307}]

    [JavaScript Error: "Conflict! Last known mod time does not match remote time! (1178018936 != 1178015336)" {file: "chrome://zotero/content/xpcom/storage.js" line: 2307}]

    After restarting firefox, the list of items re-appear but as soon as I attempt to select an item, the error occurs again.
  • Disable file syncing in the prefs until the next build, and the problem should go away. (It's happening because Zotero auto-syncs when the pane first opens, and the conflict error is leaving things in an unstable state. When you try to select an item after that, Zotero notices the problem and disables itself until restart.)
  • I disabled file syncing and re-gained access to my library.

    I then deleted a file which I had previously deleted on my mac when file syncing on the windows pc was not working. This was a pdf file which seemed to be an item in my library (rather than an attachment). It had been added as an item by accident - I had tried to drag it onto an existing item thinking this would add it as an attachment. However it seemed to add the pdf as an item.

    I then re-enabled file syncing and it seems to be working now.
Sign In or Register to comment.