Online library is full, but Zotero standalone is empty

My online library (Chrome)says I still have all of my files intact and connected to my username, but my Zotero standalone application is empty. No folders or sub folders, or anything. It is just white and empty. My error code is 1660389010.

I tried to sync and restore from the server (because it seems like my files are still on the server) but this first said there was an error with the translators and styles.

If you click OK to that message, then it continues and says that it wiped the local files, and it asks if I want to continue with the sync from the server. I press OK, and then the green sync arrow spins for a while, then it stops and either puts back the local file that I have or says the error number above, saying that my session ID is already in use or something.

This is SO frustrating and I am wondering why Zotero doesn't have a customer service line. It is way more helpful to get direct feedback from the company on trouble shooting.
  • Zotero developers read&post here, so you are getting a direct response.
    Have you tried just restarting your computer and then syncing again?
    Beyond that, Dan will have to look at this when he gets in later.
  • [JavaScript Error: "_renamedStyles is null" {file: "chrome://zotero/content/xpcom/style.js" line: 180}]
    [JavaScript Error: "Session ID already set in Zotero.Sync.Server.login()" {file: "chrome://zotero/content/xpcom/sync.js" line: 2566}]
    Try what adamsmith says — just restarting your computer — first, if you haven't yet.

    If that doesn't help, try resetting your translators and styles from the Advanced → Files and Folders pane of the Zotero preferences.
  • I have restarted my computer, as well as my translators and styles, neither works.
  • Can you provide a Debug ID from Zotero startup through the initial auto-sync, using the "Enable after restart" option?
  • It won't let me click Submit for the debug ID. It stopped the syncing green arrow but then nothing was still in my library. But the button that says Submit to Zotero Server is gray and I can't click it.
  • That should only be the case if logging wasn't enabled (such that the count of logged lines is 0). Can you try the instructions again? Be sure you're choosing the "Enable after restart" option before restarting Zotero.
  • Zotero quits and restarts when I do that, even with the enable after restart button. Once it is reopened and says it has synced (but is still empty), I go back to advanced in preferences and it is as if I never clicked enable. It is letting me click enable again, but all the three buttons below are gray, so it never started, or it started and shut down in the process of restarting.
  • Not sure what you mean. Clicking "Enable after restart" doesn't restart Zotero automatically. All that checkbox does is set a flag so that Zotero will start logging automatically at the next startup.
  • In any case, you should also be able to just disable auto-sync temporarily in the Sync pane of the Zotero preferences, restart Zotero, enable output logging, perform a manual sync, and submit the debug output if there problem still occurs.
  • Ok, here is what I got. "The Debug ID is D1599093173."
  • OK, and what happened here, exactly?
  • It shouldn't affect data syncing, but you are getting an error related to WebDAV syncing. If you're trying to use WebDAV syncing, make sure you enter a username and password into the Sync pane of the Zotero preferences. If not, disable file syncing or set it back to "Zotero".
  • I don't even know what WebDAV syncing is. I checked and I was already set to sync to Zotero.

    I am just trying to access my regular library. Zotero has worked for a year and just suddenly this happened. I never changed anything in my sync folder before my standalone emptied.
  • This process wouldn't have to take four days if you guys had a phone customer service line that I could talk to and get live feedback.
  • edited September 19, 2015
    Please remember that Zotero is free software and that most of the helpers here are volunteers. Dan Stillman is the chief developer. You are already better help here than I get from other software that offers a service contract.
    ...disable file syncing or set it back to Zotero
    Are you syncing to the Zotero site or are you using another service? Did you set up your Zotero system or are you within an institution where someone else controls your computer? There are at least two ways to sync: You can use the built-in direct sync to Zotero or you can sync to another service. Please double check that your user name and password are entered correctly for syncing. (That you can post to this forum is not necessarily an indication that you can sync.)

    Look at the detailed Zotero documentation concerning sync settings. Please be orderly in both the steps you take that are failing, the questions you ask, describe in detail what you are seeing. For example, you may need to provide screen shots of your preferences sync settings.
  • edited September 19, 2015
    Are you / were you using Zotero on more than one computer?

    Another thing, do you know _why_ your library is empty (completely totally empty?)? What happened with your computer right before your Zotero library went missing?

    You write that you use Chrome but do you also use FireFox -and- did you update or reset firefox recently? Is there a FireFox data folder on your desktop? Updating/resetting Firefox is unlikely to affect syncing but it can affect the Z standalone's ability to see your Zotero library.

    Do you have a backup system? If so you may be able to regain your Zotero in the state it was when you last used it.
  • if you're getting a WebDAV error, you very likely have something odd checked in your sync settings. Could you take a screenshot of the the sync tab in of the Zotero settings, post it to a free image hosting site (dropbox, and post a link here?

    But as Dan says, this is likely unrelated to the empty library you're seeing. Next thing to try would be to, instead of using the "Reset Styles" button, delete the folder called "styles" in your Zotero data directory

    and restart Zotero, then, again, click the reset styles button.

    Also -- is your Zotero library locally entirely empty or is there a single item ("Welcome to Zotero") in it?
  • Nothing happened before it went empty - I have been using zotero with no issues for a year. It just suddenly went empty. I am also only using Zotero on one computer, and am not using any other program, just zotero standalone and the zotero website on my chrome browser. I set up my own computer and no institution is controlling it. I reset styles on my standalone. I am trying to add a screenshot of my styles preferences but it isn't working yet.

    Update: I have been rearranging some things on my zotero through just the chrome browser, since the standalone app is being weird. I moved some sources into a new folder, and those sources I moved are now showing up in my standalone. It is almost as if it is starting to record new data, but not remembering the old ones. But they aren't sorted into any folder or anything like they are on the chrome browser.
  • I'm not really sure what's going on your system — none of this sounds like anything we usually see — but if you have all the data you want on, you can try doing a Restore from Zotero Server from the Sync -> Reset pane of the Zotero preferences. That should delete your local database and pull down all data from the server.
  • That is literally the first thing I said that I did in my original post. That restore function isn't working, that's why I knew something was wrong.
  • Close Zotero, delete your Zotero data directory, and restart Zotero.
  • I tried that, it didn't work.
  • meaning what exactly? You still get exactly the same problem when you try to sync? Could we get another debug and report ID for a failed sync?
  • It was the exact same problem. I sync and try to restore from server and it says "error updating translators and styles" and then it says data restored from local server and puts BACK the one or two local sources instead of successfully syncing from the server.
  • When you successfully delete your Zotero data directory, you should have an empty library with a Zotero Quick Start Guide with a creation data of today. Can you confirm that that's the case?
  • Confirmed. I then tried to sync from the server again and that is when it says error translation and styles and then re-restores the local data. is there a different step I should take once I delete my data directory?
  • Are you running some sort of security software on your system, or do you have your data directory on a network or in a server-mirrored home directory? The issues you're seeing are extremely unusual for a fresh data directory (or at all, really).
  • I have a Mac with no added security or virus scanners, as far as I know. My data directory was just saved in a folder on my computer.
  • There's definitely something strange going on with your installation. We don't usually recommend this, but can you 1) delete your entire Zotero profile directory and 2) reinstall Zotero from, and let us know what happens?
  • I'm having a very similar problem. Here are the points:

    1.I see my full library at
    2.Not having used Zotero for years, I've just installed Zotero standalone in a new clean install of Windows 10.
    3.I try to download the library using Preferences/Sync/Reset/Restore from Zotero Server/[Reset...]/Replace local data/Restart. Upon restart, I get the following msgboxes:
    3...Error updating Zotero translators and styles
    3...The local Zotero database has been cleared. Would you like to restore from the Zotero server now? [Sync now]
    3...The local Zotero database has been successfully restored.

    And Zotero standalone is still empty. The same happens if I go to Preferences/Advanced/Files and folders/[Reset Translators...] and [Reset Styles...]

    I've submitted debug data under Debug ID D99041326.

    Thanks for the app and the support, if you can manage it. I really appreciate what you all do.
Sign In or Register to comment.