References lost and wishes for the new year


Zotero is a really great product which I enjoy using. That said, I think there is one major problem with Zotero as a reference manager: I way too often have problems with lost references.

I use Openoffice on Linux, practically all my colleagues use Microsoft products. Therefore, I need to use bookmarks, but it happens quite often that they get changed by accident - I receive an error and can spend hours on finding the problematic reference. In some cases I experienced that I get an macro-error when I want to change from reference marks to bookmarks. Or I experience problems with moving a text from one computer to another (the latter should obviously be solved by the new version of Zotero).

In sum, I simply hesitate recommending Zotero to my colleagues. Even though I consider myself a rather skilled computer user I too often run into the problems with lost references and need to spend quite some time on re-inserting them. This is really cumbersome.

It would be a major help if it was possible to either insert unformatted references (as with this Thompson piece of software) or if Zotero was a bit "smarter" and could automatically re-insert references if the code behind has been lost (i.e., automatically look for "Smith 2008: 78" in the reference database and re-insert a proper Zotero-code; in case of multiple Smith 2008-entries, Zotero could ask for the correct one).

I still appreciate Zotero a lot, I am really grateful that this software is made available. Thank you!

Best wishes for the new year,
  • Your two feature requests are essentially for the same feature—the ability to look up and disambiguate unformatted citations—and such a feature may be added at some point.

    Just to be sure you're aware, though, exporting and importing items will currently always cause any links to those items in existing documents to be lost after importing. This will definitely be supported eventually (among other things, to allow for multi-user editing of documents).

    Also, bookmarks mode has been broken in the 1.0-compatible plugins for some time. It should work in the new 1.5-compatible plugins, but there may be bugs, so, if you're using that and get an error, follow the steps in Debugging Broken Documents and let us know. If you do what it says there and reduce in halves, you should be able to find a problematic reference pretty quickly.
  • dnh
    edited January 5, 2009
    Today, I have experienced it again - without any obvious reason, all references are lost. I worked on a text yesterday, I open it today - as done many times before, but all references are lost. Shortly before I am supposed to submit my dissertation... :-(

    PS: And it is somewhat less helpful that Zotero constantly asks whether to delete citations that supposedly do not exists anymore, makes the replacement of lost citations even more cumbersome...
  • edited January 5, 2009
    We'll need more information to be able to help.

    1) Are you using the document with the same copy of Zotero you last used?

    2) What versions of Zotero and the plugin are you using?

    3) Are you using fields mode or bookmarks mode?

    4) Are you saving the file as an .odt or a .doc file?

    5) Do you have a backup of the document? If so, you can open a copy of the backup and the broken version (before you resaved it, hopefully) and try to figure out what changed in the field/bookmark codes. (How you view those will vary depending on which mode you're using.)
Sign In or Register to comment.