Error1360227143: Updating to v1.5a1r3939

When I updated to v1.5a1r3939 from v1.5a1r3908 I got a message that the database needed to be updated. When I said 'Yes' to the update I got the error:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: anonymous :: line 127" data: no] [QUERY: INSERT INTO syncDeleteLog SELECT syncObjectTypeID, key, timestamp FROM syncDeleteLogOld] [ERROR: column key is not unique]

On attempting to open Zotero, I got an error saying that there was a problem and Zotero could not launch. I then reverted to the previous version (always have a backup). On another Zotero instance with a blank library, the database converted to the new version without a problem. Any ideas?
  • This shouldn't really possible—could you check the database integrity in the Advanced pane of the Zotero prefs? If it finds errors, run your database through the DB Repair Tool and try the upgrade again.
  • I check the database integrity and it stated there were no errors. Re-ran the update (this time r3941) and got the same error (see report id 969998969). I then tried doing a repair on the database (even though there were no errors, but just in case) using:

    sqlite3 zotero.sqlite .dump > dump.sql
    ren zotero.sqlite zotero.sqlite.old
    sqlite3 zotero.sqlite "PRAGMA auto_vacuum=1"
    sqlite3 zotero.sqlite < dump.sql

    (which should be the same as the DB Repair Tool) and updating again. Still the same error.
  • Can you dump the syncDeleteLog table to a file and send it to

    sqlite3 zotero.sqlite ".dump syncDeleteLog" > dump.sql
  • OK, thanks. Please try r3947.
  • Success! r3947 worked. Many thanks for your help, quick support and a lightning solution.
Sign In or Register to comment.