Word 2016 Keyboard Shortcut

I'm using Word 2016 and Zotero Standalone 4.0.28. Previously in Word 2011, I had Command+Alt+Z as a shortcut to Add Citation. After upgrading to 2016 and reinstalling the Word plug-in, I can't find a way to link a shortcut. If I have to mouse over to the Add-In tab of the Ribbon, mouse all the way back across the screen to icon, and click every time I have to add a reference, then Word 2016 is going to be a disaster.

I've tried changing the keyboard shortcut to the tooltip text that appears when hovering over the button: both "Zotero Insert Citation" and "Zotero Bibliographic Management : Zotero Insert Citation" but neither worked. I'm working on a piece that will likely have a few hundred citations so if anybody can help that would be much appreciated!
  • I don't know much about Word for Mac, but from what I understand, the instructions for MS Word here: https://www.zotero.org/support/word_processor_plugin_shortcuts#microsoft_word (not the one for the earlier Mac version) should work.
  • It was hard to translate it from the Windows version to the Mac (no small amount of frustration arises because there's no way to use the OS X standard way of assigning keyboard shortcuts). It turns out it's not that difficult (maybe even obvious?), just foreign to the OS X way.

    But for future reference:
    Tools menu > Customize keyboard…
    In the Categories list, select Macros
    The Zotero commands will appear in the right list. You can view and modify the keyboard shortcuts using the controls on the bottom of the dialog box.
  • thanks for reporting back. I've added your instructions at the link above.
  • edited April 17, 2016
    @samhorowitz @admasmith

    Just wanted to add that the settings that you mentioned are for Word-2016 (Mac version). It was not clear from your post whether these are for Zotero, OSX or word.

  • Hi, I also used to have keyboard shortcut, but then I upgraded Word. When I try to do the steps indicated here, I cannot find a way to add a keyboard short cut. I am not very familiar with macros in genera. Any one would have a more specific steps by steps process to add a shortcut ?

    Thanks in advance!
  • edited April 21, 2017
    Le sigh. I thought I'd lost keyboard shortcut functionality in Zotero plugin for Word since upgrading to Word 2016 for Windows. But after doing https://www.zotero.org/support/word_processor_plugin_shortcuts and resolving a "Word could not communucate with Zotero. Please ensure Firefox is running and try again" error (caused by a crashed instance of the Zotero standalone program), all is working again. Thanks, everyone!
  • Yeah, I've also tried this just now and it works. But does anyone know how to make the classic view show up by default?
  • There's a preference in the Cite tab of the Zotero preferences for that.
  • I tried using the instructions for adding a keyboard or ribbon icon for Zotero on the a new mac using Word 2016. Something seems different from the instructions listed previously, which were: Tools > Customize Keyboard > Categories > Macros. The problem is that Macros is not listed in that dialog box.
  • Do you see the Zotero tab in the Ribbon?
  • I'm not seeing anything that suggests a Zotero affiliation. Where the Z icon used to appear near the Tools tab, now there's just Help. There is a citation manager embedded in the program that is a MS/Bing tie-in.
  • Okay, then the issue is that the Zotero plugin isn’t loading in Word for some reason. Go through the steps for “Zotero toolbar doesn’t appear” here:
  • I can confirm that this also occurs for me. I tried using the instructions for adding a keyboard or ribbon icon for Zotero on the a new mac using Word 2016. Something seems different from the instructions listed previously, which were: Tools > Customize Keyboard > Categories > Macros. The problem is that Macros is not listed in that dialog box.
  • Agreed, new Word version as part of Microsoft 365 (Version 1902) does not have any Zotero macros listed when you get to that portion of the Customize Keyboard settings.
  • I diden´t get it. I have the new version of Word 365 (2019) and I can´t change shortcut´s for my citations. Also inside the upper menu bar is no Zotero booklet any longer. Can someone help me ?
  • I there is even not the possibility to use a command shortcut because there is no one...
  • edited September 15, 2019
    Yes, you certainly can set keyboard shortcuts for the Zotero commands or any other Word command. The process hasn’t changed. https://www.zotero.org/support/word_processor_plugin_shortcuts

    I don’t understand what you about the menu bar. Are you saying the Zotero tab isn’t in the ribbon?

    (Feel free to write in another language if you prefer.)
  • I already found the following solution... But the explanation I have tried faild...
  • We really need more information to be able to help you. Do you see the Zotero tab in the Word ribbon?
  • I have the Zotero buttons in the menu bar of my word window. But for example in former times I could also find zotero in the upper part in the main menu bar of my mac. If I try to use the command "Add/Edit Citiation" there is no way. I can only make citations in case I click the button in the menu bar of the word window.
  • Oder um es nochmal in Deutsch zu sagen ich vestehe das mit den macros nicht. Wenn ich in die tastaur einstellungen gehe und es versuche so einzustellen wie früher kann ich das für das Programm word oder zotero probieren. Aber beides funktioniert nicht.
  • Sollen die macros die "App-Tastaturbefehle " sein?
  • Ich danke dir schonmal für deine Hilfe. Aber ich bin echt am verzweifeln...
  • Die alten Befehle im Apple Script Menu gibt es nicht mehr.
    Die Shortcuts werden in Word eingestellt unter "Entwicklertools" und dort unter Macros. Dort solltest Du die verschiedenen Zotero befehle finden. Wenn nicht, dann müsstest Du idealerweise ganz schrittweise erklären was Du machst und wo genau Du steckenbleibst, also so wie "In Word clicke ich auf das Tab Entwicklertools und dann... usw"
  • Yesterday, I could follow all these steps on a MPB 2017, macOS 10.15.5, Word for Mac Version 16.37, and Zotero 5.0.87.

    Today, my shortcut only produces a question mark in a box within the Word document.

    When I go: Tools > Customize Keyboard... > Macros the right field is completely empty. What is going wrong here?

    *Yes, I have tried on and off again*
  • edited June 9, 2020
    @fthielen: Does the Zotero plugin still show up and work in Word? If the plugin is installed, you should definitely see ZoteroAddEditCitation and similar in the list when you click on Macros in the Customize Keyboard window.
  • @dstillman: yes it does. It works just fine otherwise.
  • @dstillman: my Word installation didn't change in the meantime. And before I was able to set this shortcut.

    What I do see is:

    Tools > Macro > Macros...
    Macros in: Zotero.dotm (global template)

    Here I can find all the Macros of Zotero but not set a shortcut.
  • @dstillermann:
    Thanks. But I did follow the instructions and there I cannot select any Macros.

    I mention the other dialogue above to show that the Zotero Macros are apparently available in Word but just not through the route in the instructions (whereas they were just two days ago).

This discussion has been closed.