JSTOR translator not working (Firefox)

I read the discussion about JSTOR translator in Safari, discussion which ended by a remark of auschi (Jul. 16th 2015) who said "I have not been able to find any workaround or discussion of how to deal with this problem in Firefox. It seems most people have the problem in Safari or Chrome, but I cannot save from JSTOR using Zotero in Firefox. I can't seem to find the right thread. Is there one? Or am I the only one having problems getting JSTOR to speak to Firefox?"

I did not find the new thread he/she was supposed to create, so here is one (please redirect me if the thread actually exists)

I logged in into JSTOR via my university library, and tried import the data.
Usually - some months ago, because I did not use it for some time - it allowed me to retrieve the data of the paper and the pdf.
I tried the two possible options (using JSTOR and DOI), but no one of them works : a pop-up opens as usual, but it is empty (this usually shows that no information is downloaded).

It is all the more a pity that the pdfs contain no metadata, so the process would be to save as webpage (this works) and manually add the information, and then link the pdf (manually downloaded).

I guess we are more than two to have this problem (I use Firefox 39 on Ubuntu, and Zotero 4.0.28), and I hope you'll be able to fix it soon.

Thank you for your help,

  • Please see the relevant steps here https://www.zotero.org/support/known_translator_issues and provide information requested in step 11
  • Report ID: 644791923

    Thank you. I disabled some Firefox add-ons (though they were not in the "black-list", and tried anew.

    It results that when I log in to JSTOR through my personal account, and go to a paper, I can retrieve data (with the paper-icon), and download pdfs.
    BUT when I log in through my library, for the same paper, and using the same steps (+ the log in to my library account), I cannot retrieve any data (the pop-up "enregistrement en cours" appears but stays blank).

    Having read the error report, I guess it could be connected to the fact that my library (Bibliothèque Diderot de Lyon) uses an invalid certificate, but there is also something in it about a translator, which I do not really understand. I'd be happy if you could tell me what to do.
  • Addition : connecting through the same institution, I can retrieve data and pdf from other databases (I tested successfully with the "Project MUSE").
  • what's the URL for JSTOR when logged in through your library exactly as you see it?
  • Oh, sorry, I thougt I had put it : http://www.jstor.org.acces.bibliotheque-diderot.fr/stable/636021?seq=1#page_scan_tab_contents
  • It works ! I got a Firefox warning (the one with the choice between "get me out of there" and "I understand the risks"), I added the exception, and then I could retrieve the data. How can you explain that ?
  • And, if course, thank you very much :-)
  • JSTOR refuses to serve the citation data over anything but https and, rather oddly, your university proxy doesn't seem to have a valid certificate. (And then you get a translator error because Zotero expects the citation data but gets an error page instead).
  • Thank you for the explanation.
    I noticed that invalid certificates were often originating from academic institutions, so I got used to it, but I had not have any problems with that before.
  • edited August 6, 2015
    [JavaScript Error: "www.jstor.org.acces.bibliotheque-diderot.fr:443 uses an invalid security certificate.

    The certificate is only valid for the following names:
    acces.bibliotheque-diderot.fr, acces2.bibliotheque-diderot.fr

    (Error code: ssl_error_bad_cert_domain)
    You should really speak to your IT department rather than whitelisting the certificate. (In this case there's not much of a security issue, but you should never whitelist a security certificate unless you understand the reasons for it and what the consequences are for that specific exception.) And you'll also probably get a similar warning trying to access any proxied site that uses HTTPS that you haven't already whitelisted in your browser.
Sign In or Register to comment.