"Zotero experienced an error updating your document"


A couple of days ago I continued to edit a text that had had some bibliography that I inserted using zotero. I added some new items to the database, and when I was adding citations, I started getting error messages with the following texts:

The first one:

"The Zotero field code corresponding to this citation, which tells Zotero which item in your library this citation represents, has been corrupted. Would you like to reselect the item?
Clicking "No" will delete the field codes for citations containing this item, preserving the citation text but potentially deleting it from your bibliography."

The second one:

"Zotero experienced an error updating your document.
Document modified during update @[setCode:field.m:585]"

After these two messages the cursor selects one of the citations in the document.

I tried
1) Restarting word 2011 on mac
2) Restarting zotero
3) Restarting computer
4) Erasing citations that the cursor selects after these messages and adding them again — they were selected again.

This did not help.

5) I was working tracking changes. I accepted all changes, turned the tracker off, and then inserted a citation. No error messages appeared.

Is there a way to repair this so that it worked when the tracker is on?
  • I am also having this problem. I am trying to change the referecing style and at some point in the document Zotero gives me this error. Any help?
  • Which exact Word and Zotero versions and what's the exact error message you're getting?
Sign In or Register to comment.