Can't load visual basic for applications error

Error id: 446974423

I'm running ZFF with Word for Mac 3.5.11 on OS 10.10.4 running MS Word 2011.

When I try to add a citation in Word from the Zotero menu I'm getting a "Can't load visual basic for applications error" message.

When I look in my MS-Office folder, visual basics for applications is installed.

The path is:
iMac SSD: Applications: Microsoft Office 2011: Office: Visual Basic for Applications.framework: Visual Basic for Applications

I have tried closing Word and reinstalling the plugin.

I have tried deleting the OLE database.

Here are the contextual complications: it is the first time I am trying to add a citation on the present computer. I migrated to this 2011 iMac from a Mac Mini a few months ago using the Migration assistant. The applications were all installed on to an internal SSD hard drive, with data on the internal SATA drive. I then partially moved from Canada to Europe and do not have the Word installation disks with me. The date on the Visual Basic for Applications file is the date I migrated the data.

Thanks in advance for help!
  • Okay, I managed to get a copy of Office 2011 and did a custom install for just Visual Basic for Applications.

    I then restarted, then deleted the OLE database again and launched Word.

    I am still getting the same error message.

    New error report id: 1931697394

  • @ Dan Stillman, would really appreciate any help you could provide with this problem!

Sign In or Register to comment.