Zotero can't sync despite valid credentials

Hi there,

I am trying to get my Zotero-Firefox pair back in working order. The previously working setup was a Zotero database + external WebDAV sync that got broken somewhere weeks ago.

I did reset the password here and cleared FF's cache, but Zotero client keeps on saying my credentials are invalid, that I should delete signons.sqlite (which I did). On the website though, it works.

How do I reconnect Zotero client back to its database server? I don't understand the dialogue shown since it works on the Web.
  • What's the exact error message you're getting? Don't paraphrase or translate.
  • That:
    Zotero ne peut pas accéder à vos informations de connexion.

    Si vous utilisez un mot de passe maître dans Firefox, assurez-vous de l'avoir saisi correctement.

    Ce pourrait être également causé par la corruption de la base de données du gestionnaire de connexions de Firefox. Pour vérifier, fermez Firefox, supprimez signons.sqlite dans le répertoire de votre profil Firefox, et re-tapez vos informations de connexion Zotero dans le panneau Synchronisation des Préférences de Zotero.
  • Yeah, so that's a Firefox issue, not a Zotero one, but I believe that error message is out of date. Try moving key3.db, cert8.db, and logins.json out of your Firefox profile directory instead and restarting Firefox. (You'll need to re-enter saved passwords, including the Zotero ones.)

    Let us know if it works after that.
  • Sorry it doesn't work any better.

    Oh, and trying to verify the external WebDAV server doesn't work either, message is:

    Une erreur indéterminée est survenue. Veuillez vérifier vos paramètres de synchronisation de fichier ou contacter l'administrateur de votre serveur WebDAV.
  • Nothing that requires a password will work, because Zotero can't access the Firefox password manager. Are you able to save and access passwords from websites?

    If you're running any security software, try disabling it. Same for any other Firefox extensions.
  • Hello,

    I have a similar problem. After almost losing all my files because of a problem with my computer, I decided to upgrade my Zotero account so that I could sync.

    The problem is, it is not syncing! I still get the message "your zotero account limit is exceeded", despite having used 0% of my file storage.

    Can you help me?

    Best wishes,

  • @fabor -- different issue, please start a new thread ("Start a New Discussion" at the top left).

    Make sure you're syncing with the same username you're using to login here.
  • The servers connections seem to be working, but I still get sync errors. First, it is extremely slow, second, it fails without explanation about an hour after starting.

    I captured an error message with ID 553684482.
Sign In or Register to comment.