Edit citation style for Methods in Ecology and Evolution

Dear all,

I am intending to submit a paper to MEE but the style available on Zotero does not quite match the journal requirements.

Here are the differences:
1) For journal articles: the volume is in bold but should not be
2) The retrieved information is added but it is not requested by the journal. For example: "Retrieved February 18, 2015" should not appear at the end of the reference in the bibliography
3) In the text: works from the same first author and date are correctly coded with letters, but are separated with semi-colon instead of comma. For example: "Someone et al. 2012a;b" should be "Someone et al. 2012a,b"

If I am correct, I think the first problem should be corrected by editing this line and changing "bold" to "normal":
<text variable="volume" font-weight="bold"/>
It seems to work but I hope I didn't change something that should not have been...

Regarding problem 2, this is probably here:
<macro name="access">
<text term="retrieved" text-case="capitalize-first" suffix=" "/>
<date variable="accessed" suffix=", ">
<date-part name="month" suffix=" "/>
<date-part name="day" suffix=", "/>
<date-part name="year"/>
<text term="from" suffix=" "/>
<text variable="URL"/>
But I don't think I should just delete it, as it is important in the case of websites

For problem 3, I have no idea.

Thanks in advance!
  • edited May 13, 2015
    1) The example in the author guidelines are different from the real practice in the journal. I checked a few current articles and they have volume number bold. Thus, I guess hat bold is what they want.
    2) Currently, the access macro is shown always, when there is either an access data or url present. We can restrict that to websites. Or is there any other case when the style should to show the url and access information?
    3) Okay, we can change that with a year-suffix-delimiter="," see spec

    I can do the changes later in the repo.
  • 1) I agree with you; I've just checked again

    2) The access date should be shown only for websites. Here is the only example given: "-R Development Core Team (2009) R: A Language and Environment for Statistical Computing. R Foundation for Statistical Computing, Vienna. URL http://www.R-project.org [accessed 18 November 2009]"

    3) Where would you insert it? Here like this?
    <citation collapse="year-suffix" et-al-min="3" et-al-use-first="1" disambiguate-add-year-suffix="true" year-suffix-delimiter=",">

    Thank you!
  • I fixed 2) and 3) and yes it looks as you suggested in 3).

    The updated version will appear on the repository within 30mins (check the timestamp). Update your copy of the style by clicking "Update Now" in the General tab of the Zotero preferences.

    Styles also update automatically within 24hs for Zotero 4.0+
    In an existing document, you may have to switch to a different style and back for the changes to take effect once the style is updated.

    Any further problems please let us know & thanks for reporting
  • Sorry to answer that late, but everything works perfectly now!
    Thank you for your help.
  • Dear @zuphilip,

    Inline citations are not being sorted by year for me. I used the "visualEditor" to add a macro for date (same way of Global Ecology and Biogeography style) and downloaded for using on my computer. Would be nice if you could check this issue on the repository. Thank you
  • edited March 30, 2018
    Just checked. this style is currently a dependent of apa-old-doi-prefix.csl.
    And it does need sorting by year in in-line citations and not by author.

    Independent style made: https://github.com/citation-style-language/styles/pull/3199
  • Great! Thank you!
Sign In or Register to comment.