"There was an error starting zotero"

Suddenly my zotero firefox add-on was gone, so I had to install it again, but then there comes an error everytime "there was an error starting zotero". I have never had this problem before.

I restarted firefox, computer, and re-installed firefox, still the same. Also tried all the steps on your installation issue page, nothing happens. I use zotero everyday and I need it to work asap.

What can I do about this?
  • We'll need the info here, then:
  • Like this?
    TypeError: History.getState is not a function
  • TypeError: $tree.dw_tree is not a function
    ReferenceError: dw_locktimer is not defined
  • yeah, but all of the relevant ones. Also, which Zotero version do you have installed, which Firefox version? (Check the Zotero version under tools --> addons in Firefox, the Firefox version in Help --> About Firefox).
  • "Firefox is up to date" 37.0.1
  • Those should be the newest one.. any suggestions how to proceed?
  • I'm waiting for Dan to respond to https://forums.zotero.org/discussion/48463/error-starting-zotero-even-after-install/ which I suspect might (!) be related.
    Have you tried disabling all other Firefox add-ons (particularly those related to Zotero) and restarting?
  • I use adblock plus, clearly, diigo and integraded google calender. Can those be a problem? They have never been before though.
  • Unlikely, but always good to check. It's just for testing, I'm not saying you shouldn't use them.
  • Those errors you post above aren't relevant, but if you're seeing "SyntaxError: missing ; before statement http.js:1000:1", see the thread adamsmith links to.
  • edited April 21, 2015
    Only these errors shows up:
    ReferenceError: dw_locktimer is not defined js.php:1:771748
    TypeError: $tree.dw_tree is not a function js.php:1:360173
    TypeError: History.getState is not a function _zoterowwwAll.bugly.1429126755.js:4478:20

    I also disabled all other add-ons and tried, no different.

    Now I just uninstalled firefox and deleted all firefox files under local and roaming. Installed it again but nothing happen, same error.

    Further suggestions?
  • Still no relevant errors in there. Can you provide real-time debug output for Firefox startup? (If it's long, you can email it to support@zotero.org with a link to this thread.)
  • Here it is: https://www.dropbox.com/s/irp5sz6nxmckkum/debut_output.docx?dl=0
  • edited April 21, 2015
    SyntaxError: missing ; before statement http.js:1000:1
    Right, that's the same issue as in the other thread. We really don't know what's causing this, so the best we can suggest is what worked for the other person.
  • He is writing this "I deinstalled Firefox again, but this time I deleted all Mozilla directories in AppData folder of my Windows Profile. I reinstalled Firefox and then Zotero and now it seems to be working fine."

    If you look above I did this too, also deleted the files in appdata. Installed firefox again and the same happened.. I can try one more time though.
  • Right, I understand, but I'm saying we don't have any other info on this yet, since we don't know what's causing it on the few systems where it's occurring.
  • I understand. Your feedback has been quick, good support you have.

    I will try to uninstall it again, I can also try to install zotero before I log on my firefox user, if that can make a difference. Hopefully it will work after firefox updates their software maybe..

    I also runned my malware and ccleaner program, no change. The strange thing was that when I was in my firefox browser I noticed that my add-ons were gone, no idea of what causes that to happen. Then when I installed zotero again, this problem came.
  • I finally got a reply from firefox support:

    "The Syntax error indicates that there is something wrong with one of the files that makes up the Zotero plugin, it could be malware related. It could be caused by a bug in Zotero, or it could be the result of memory corruption or bit rot- but it's not going to be a Firefox problem. Firefox is correctly reporting that there is an issue with the Zotero plugin itself.

    Have you tried uninstalling and re-installing Zotero?"

    I have runned both Ccleaner and Malwarebytes Anti-Malware programs. Is there any program here you would recommend me to run beside this?
  • Finally. I have tried different malware programs without any help, then I tried "SUPERAntiSpyware Free Edition" and it removed some malware and now it works!!! Thanks for the help :)
  • edited April 27, 2015
    Yeah, that Firefox support reply is mistaken, of course — it's none of those things (except malware, it seems). Do you happen to have a log of what malware was cleaned up when the problem went away? If so, could you send it to support@zotero.org with a link to this thread?
  • Yes, you can download it from here:
  • OK, thanks — you can remove that now.

    That doesn't actually show anything relevant being detected, though, as far as I can tell, so I'm not sure that was actually what fixed it. It's possible that one of the other programs cleaned it up but Firefox wasn't fully restarted until you ran the last one.
  • Hm, I have used my regular spy-ware everyday lately, when I used it today it actually said restart is required. Then I finished the other program, the one you just saw the log to, and restarted. Have a look at this log then:
  • Files: 2
    PUP.Optional.MultiPlug.Uns, C:\Program Files (x86)\ActiveDiscount\ActiveDiscount.exe, Quarantined, [6827f67b692143f3bed7eb546f94f50b],
    PUP.Optional.Multiplug.A, C:\Program Files (x86)\Mozilla Firefox\dbghelp.dll, Quarantined, [7c13472a5b2fdb5b8f1c82ca679be818],
    OK, thanks. ActiveDiscount is definitely malware that interferes with browsers, and that second one might have been its (or something else's) injection point into Firefox. (dbghelp.dll can be a valid file, but I don't have it in any of my Firefox installations.) Not sure why clearing Mozilla data files (as opposed to installation files) is fixing this for some people, though.

    In any case, we'll look out for any correlations with the above from other people reporting this.

    Thanks again.
Sign In or Register to comment.