JSTOR translator trouble (ZSA & ZFF)

Report ID: 1148702273, 69104008

I'm unable to save anything from JSTOR to Zotero. This happens with both Zotero for FF & the Chrome and Safari connectors to Zotero Standalone.

An example of a link that doesn’t work:

I get a folder icon in the address bar that says “Save to Zotero (DOI)”. When I click to save, I get “Saving item…An error occurred while saving this item. Check Known Translator Issues for more information.”

I know about the two known issues with JSTOR — I have access to JSTOR & I’m downloading one PDF per session before trying to import to Zotero.

I've tried saving NYT articles in all three browsers and that works as usual. This seems to be JSTOR-specific.

I've used JSTOR & Zotero together successfully for years. But I'm just returning to Zotero after a year away, so I don’t know if these are recent problems or I’m just seeing them now.

Everything seems to be up to date. I’m using OSX 10.10.2, Zotero, Firefox 37.0.1, and Chrome 41.0.2272.118 (64-bit) with Zotero Connector (I’ve also gone through all these steps with Safari, but it looks from the forums like it has its own set of translator problems lately.)

I don’t see anyone else having this problem, so I suspect something's wrong with my configuration. But I've gone through all the steps in troubleshooting translator issues with no luck.

Thanks for any insight! And for making Zotero work. It’s amazing.
  • With this type of proxy, the only configuration that can possibly work is Zotero for Firefox. So start by confirming that you get exactly the behavior your describe (including the (DOI) in parentheses) for Zotero for Firefox with Zotero Standalone closed.
  • Thanks -- yes, I get exactly this behavior using Zotero for Firefox with Standalone closed.

    I also notice that I'm getting a prompt to add this proxy every time I log in through upenn to get to a JSTOR article, even though it's already been added -- not sure if that's relevant/useful.
  • Sorry, to be clear -- I get this exact behavior, including the (DOI).
  • Other gated resources work OK? And for those, do you see the regular URL domain (say sciencedirect.com or springerlink.com ), or is that masked by the upenn proxy as it is for jstor.org , too?
  • They're all masked by the upenn proxy, but still working to save citations. Instead of the folder and (DOI), I get the document icon and (databasename) -- tried this with sciencedirect, pubmed, and projectmuse.

    I don't know if this is connected, but when I save citations in these other databases Zotero's failing to attach PDFs. The PDF filename will show up in the "saving..." window but then a red x appears next to it, so Zotero does see the PDF and try to attach it.
  • (Which is fine -- downloading & attaching PDFs manually is easy. Just passing this on in case it's connected in any way to this weird proxy/JSTOR behavior.)
  • Just giving this a bump -- still having this problem, would love any help/insight. Thanks!
  • Giving this another bump -- I'm still having this issue. Any suggestions about what might be going wrong or what I can try? Thanks for any advice!
  • It's something about the Penn proxy that prevents Zotero from recognizing the site as JSTOR. Best I can suggest as of now is to use UPenn VPN instead of the proxy.
  • Thanks, adamsmith. Unfortunately as a grad student I can't use Penn's VPN.

    Is this something that could get fixed someday in Zotero? Or does it depend on Penn adjusting something about how its proxy works?

    Can you explain (or point me to an explanation of) what's happening with the proxy that's flummoxing Zotero, so I can bring the issue to the attention of the library or the IT people in our dept?

    It's weird because I used Zotero via proxy successfully for years. So either something changed in Zotero or in the upenn proxy -- just trying to trace the problem.
  • edited May 19, 2015
    Or I guess something could have changed in JSTOR -- ? In which case I'll give up hope.
  • Any thoughts on this? It would be great to get the bottom of the proxy problem and/or figure out a workaround besides VPN. For now I can't use Zotero with JSTOR at all.
  • It's working now! As of yesterday, I get a journal icon tagged "Save to Zotero (JSTOR)", and the citation shows up in Zotero. Don't know what changed, but I'm so pleased.

    Also -- the PDF-attaching problem I mentioned turns out to be because I was blocking third-party cookies in FF. I turned that off and everything's fine.
  • nothing on our side, oddly. So I suspect UPenn was doing something weird there with the proxy which they changed/fixed. But very glad it's working for you.
Sign In or Register to comment.